[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

cyradm error (...authentication failed)

I am trying to get virtual email domains running with postfix and cyrus. I installed them both from I apt. I haven't gotten very far and am now getting errors when trying to use cyradm. It seems like this is a somewhat common error according to my googleing, but I have not been able to find a solution. I running woody with the woody apt sources.

I added a cyrus user to the sasldb via:

# echo password | saslpasswd -p -c cyrus

I checked the /var/log/auth.log and it tells me:

saslpasswd: PLAIN: set secret for cyrus

so it looks like it is set right. but when I use cyradm I get the following:

# cyradm -u cyrus localhost
localhost password:
application-spacific initialization failed: authentication failed

So, what could I be doing wrong?  Here is my imapd.conf if it will help:

# Debian Cyrus imapd.conf
# See imapd.conf(5) for more information

# Configuration directory
configdirectory: /var/lib/cyrus

# Which partition to use for default mailboxes
defaultpartition: default
partition-default: /var/spool/cyrus/mail

# News setup
partition-news: /var/spool/cyrus/news
newsspool: /var/spool/news

# Uncomment the following and add the space-separated users who
# have admin rights
admins: cyrus mailadmin

# No anonymous logins
allowanonymouslogin: no

# Minimum time between POP mail fetches in minutes
popminpoll: 1

# umask used by Cyrus programs
umask: 077

#sasl_pwcheck_method: saslauthd
pwcheck_method= sasldb

If you notice those last two lines, I have tried with and without both with the same result. I also created a real user named cyrus and game it rights to sasldb... and tried all of the above logged in as cyrus.

any ideas?

thanks a million!

Bernie Berg            |  bberg@circadesign.com
Network Administrator  |  Office:(605)362-6361
Circa Design Company   |  Cell:(605)359-2237

Reply to: