[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Boot/root disks


This is slightly off topic but I haven't had much luck with this so I thought I'd ask here.

I have installed and configured Debian with many packages and a custom kernel, which I have then imaged using the partimage package. I want to then use this to replicate this image onto multiple machines of the same hardware. These machines have a floppy drive and network card but no CD-ROM drive. I have tried to boot off both the debian install and partimage/slackware boot and root disks but neither of these will let me run the TFTP client, which I want to use for downloading the images from my TFTP server and restoring them on the local disk. The network setup is fine (pings are fine, routes are fine, the tools in these images provide for little else in the way of troubleshooting), but when the tftp client is run it exits with this message:

tftp: tftp/udp: unknown service

when using tftp version 0.1.0 or

tftp: tftp/udp: unknown service, faking it...

when using tftp version 0.2.9.

I've tried copying over /etc/services to the /etc directory after booting up with either of the root images but get the same result. I can't use FTP or telnet because of missing libraries in the root images, but TFTP is fine for what I want to do.

Has anyone seen this before? Is there something I am doing wrong? Is there a good alternative root image somewhere which I can use instead of the debian/slackware/partimage ones which can run the TFTP client without problems? Is there a better way of doing this short of using NFS , the crappy partimage network client or directly imaging from one hard drive to another (my last resort, the cases are rather small and hard to work with).



To UNSUBSCRIBE, email to debian-isp-request@lists.debian.org
with a subject of "unsubscribe". Trouble? Contact listmaster@lists.debian.org

Reply to: