[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Could not early remove libpam0g

computer:# apt-get -f dist-upgrade
Reading Package Lists... Done
Building Dependency Tree... Done
Calculating Upgrade... Done
The following packages will be REMOVED:
  libpam0g-util lynx newt0.25 ppp-pam rgrep secure-su slrn xproc
The following NEW packages will be installed:
  bootpc finger fping freetype2 fte-xwindow ftp gdk-imlib1 gettext-base
gnome-libs-data icmpinfo imlib-base libart2
  libaudiofile0 libbz2 libcdparanoia0 libconvert-ber-perl libglib1.2 libgsm1
libgtk1.2 libgtkmm libguile6 liblockfile1
  libmon-perl libmysqlclient6 libncurses5 libnewt0 libnspr3
libopenldap-runtime libopenldap1 liborbit0 libpam-modules
  libpam-pwdb libpam-runtime libpcre2 libpopt0 libreadline4 librecode0
libssl09 libtiff3g libungif3g liburi-perl libwrap0
  lockfile-progs perl-5.004 perl-5.004-base perl-5.004-doc perl-5.004-suid
pidentd rdate rdist rsh-client ruptime rusers
  rwall rwho rwhod samba-common tcl8.2 tcl8.3 tcpd tftp tk8.3 traceroute
vflib2 xaw-wrappers
The following packages have been kept back
  acct cvs gedit inn kbd libhtml-parser-perl libmime-base64-perl mon xbuffy
92 packages upgraded, 65 newly installed, 8 to remove and 10 not upgraded.
Need to get 0B/56.2MB of archives. After unpacking 51.0MB will be used.
Do you want to continue? [Y/n] y
E: This installation run will require temporarily removing the essential
package libpam0g due to a Conflicts/Pre-Depends loop. This is often bad, but
if you really want to do it, activate the APT::Force-LoopBreak option.
E: Internal Error, Could not early remove libpam0g

Have tried the following:
        apt-get update
        apt-get -f dist-upgrade

Reply to: