[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

RE: apache 1.3.23 ipv6 binary

Sjoerd Simons [mailto:sjoerd@air.luon.net] wrote:

> On Sun, Jul 14, 2002 at 12:32:26AM +0200, Jeroen Massar wrote:
> > I still don't know why it's there... is it because people
> > "open up ports in ipv6 which they firewall in v4" or ???
> See bug #82468. It's an incompatibility in the linux 2.2 kernel ipv6
> structures and the glibc 2.2 ipv6 structures. One could argue 
> it's a system  misconfiguration, but the ssh package maintainer choose
> the --ipv4-default workaround apparently. 

Now I remember :)
But isn't that where the depends and conflicts are for ?
Depends: libc6 (>= 2.2.4-4), kernel-image (>= 2.3)
Conflicts: kernel-image (<< 2.3)
But then this would force users to upgrade to 2.4 and not anybody wants
Other tactic:
Package: ssh
Depends: (ssh-kernel22 (= 3.4p1) & kernel-image (<< 2.3)) ||
(ssh-kernel24 (= 3.4p1) & kernel-image (>= 2.3))
A small pseudo package requiring the correct version depending on
Though this one very probably won't work with current dpkg <grin>

Or the 'easy' way would be adding a seperate package called ssh-ipv6 or
ssh-kernel24 in the maintree, then put a little
check in the main ssh package, and ask the user if he/she/it/...
wouldn't rather have a ipv6-default supportin version
as he/she/it/... is using a newer glibc&kernel :)

This still only 'fixes' SSH...


To UNSUBSCRIBE, email to debian-ipv6-request@lists.debian.org
with a subject of "unsubscribe". Trouble? Contact listmaster@lists.debian.org

Reply to: