[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: Fwd: Problem installing openssh in debian-interix

Hi Martin,

Thanks for your reply.

On 07/01/2013 07:17 PM, Martin Koeppe wrote:

On Sat, 29 Jun 2013, Raghavendra wrote:


I have installed Debian interix on my Windows 7 system with SUA 3.5.

Are you sure, you have SUA 3.5? Windows 7 Ultimate and Enterprise come with SUA 6.1 included.
I may be wrong with the version of SUA, but i am using Windows 7 ultimate. And I enabled SUA from it.

I have followed the instructions for installation given in the debian-interix web site. I have configured debian-interix to Unreleased35 as explained in the intallation guide.

After that I tried to install open ssh using command apt-get install openssh-server. The installation ended with following error :

Unpacking openssh-blacklist (from .../openssh-blacklist_0.4.1+nmu1_all.deb) ... dpkg-deb: file `/var/cache/apt/archives/openssh-blacklist_0.4.1+nmu1_all.deb' contains ununderstood data member data.tar.xz , giving up

Yes, this may be a problem for current debian packages. Dpkg evolves, and .xz support has been added. I currently don't maintain debian-interix anymore, mainly because of (1) several annoying "kernel" issues which only MS could fix, but doesn't, (2) missing 64-bit support for gcc and shared libs (.so), and (3) MS has deprecated SUA since Win 8.

So, the debian-interix dpkg doesn't understand .xz, but newer arch-all packages are packaged with it. You cannot install these packages, unless you update dpkg first. Maybe you can switch to stable for arch-all, or even oldstable.

So, How can i update my dpkg for debian-interix? I tried looking for any online help but didnt find much. Could you please explain more about "Maybe you can switch to stable for arch-all, or even oldstable.", does it mean to use older versions of OpenSSH? If so can please let me know how can i change the configurations.
After this when i try ussing SSH. SSH client is working fine but SSH server is not working.
Can you please let me know how this could be fixed.

At the time I built the ssh-server package it did work, but that was on Vista and below. I didn't have Win 7 at that time. What error do you encounter? Does the server start at all? You need to start manually, it's not automated currently, no init scripts are run by default. Or do you get error messages? Did you open port 22 in firewall? Do you have 32bit or 64bit Win 7?
I am not sure if ssh-server has installed sucessfully, because i got this error while installing the server:

Unpacking openssh-server (from .../openssh-server_1%3a4.7p1-9+interix.3_interix-
i386.deb) ...
Errors were encountered while processing:
E: Sub-process /usr/bin/dpkg returned an error code (1)

I am using Windows 7 ultimate 32 bit version.


Thanks for your responses again, Hoping i could fix this issue. As it is crucial for me to have ssh server running in order to install open grid scheduler.


Reply to: