[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: Debian installer

On 09/04/2018 08:28 PM, Frank Scheiner wrote:
Unfortunately both 4.17.0-2 and 4.17.0-3 do not work on my rx2800 i2. Shortly after loading the initramfs the machine resets without further output in between:
A Gentoo Linux kernel 4.14.65 works fine on the rx2800 i2 (and also the above mentioned machines). I'm unsure if this is due to that single ia64 patch Gentoo is using (see `1700_ia64_fix_ptrace.patch` on [1]) or if something break in later kernel versions. If time allows I will try to compile a more recent kernel as there were some patches for ia64 added recently ([2]) and see how it behaves on my rx2800 i2.

[1]: https://dev.gentoo.org/~mpagano/genpatches/trunk/4.14/

[2]: https://github.com/torvalds/linux/search?q=ia64&unscoped_q=ia64&type=Commits

Some update:

I first tried a vanilla kernel 4.18.6 with the above mentioned patch applied on my rx2800 i2. Unfortunately that didn't fully work on the rx2800 i2:
Linux version 4.18.6 (root@rx2800-i2) (gcc version 7.3.0 (Gentoo 7.3.0-r3 p1.4)) #3 SMP Wed Sep 5 21:56:26 CEST 2018
Trying to unpack rootfs image as initramfs...
Freeing initrd memory: 12048kB freed
Unable to handle kernel NULL pointer dereference (address 0000000000001688)

**But** the same kernel worked well on my rx2620! So zx1 (and most likely also zx2) based systems might be readily supported by the current Linux kernel version in Sid.

Applying the above mentioned patch to the Debian kernel source for 4.17.0-3 (i.e. 4.17.17) and "manually" compiling a kernel makes it not fully working on my rx2800 i2 **but** at least we now get kernel messages:
[ 0.000000] Linux version 4.17.17 (root@rx2800-i2) (gcc version 7.3.0 (Debian 7.3.0-22)) #1 SMP Fri Sep 7 17:46:52 UTC 2018
[    0.000000] EFI v2.10 by HP:
[ 0.000000] efi: SALsystab=0xdfdd63a18 ACPI 2.0=0x3d3c4014 HCDP=0xdffff8798 SMBIOS=0x3d368000
[    0.000000] booting generic kernel on platform dig
[ 0.000000] ACPI: XSDT 0x000000003D3C4580 000124 (v01 HP RX2800-2 00000001 01000013)
[   14.006350] Unpacking initramfs...
[   14.763489] Freeing initrd memory: 21344kB freed
[   21.801341] Freeing unused kernel memory: 992K
[   21.871028] This architecture does not have kernel memory protection.
Loading, please wait...
starting version 239
[ 22.119283] igb: Intel(R) Gigabit Ethernet Network Driver - version 5.4.0-k
[   23.288995] GSI 19 (level, low) -> CPU 7 (0x0700) vector 84
[   23.372110] ehci-pci 0000:00:1a.7: EHCI Host Controller
[ 23.447611] Unable to handle kernel paging request at virtual address 00000000000076c8 [ 23.476683] igb 0000:08:00.1: Intel(R) Gigabit Ethernet Network Connection
[   23.451611] systemd-udevd[143]: Oops 11012296146944 [1]
[ 23.451611] Modules linked in: uhci_hcd(+) ehci_pci(+) ehci_hcd usbcore igb(+) i2c_algo_bit i2c_core usb_common [ 23.663818] igb 0000:08:00.1: eth1: (PCIe:2.5Gb/s:Width x2) 00:23:7d:45:30:71
[   23.451611]
[   23.451611] CPU: 6 PID: 143 Comm: systemd-udevd Not tainted 4.17.17 #1
[   23.451611] Hardware name: hp Integrity rx2800 i2, BIOS 01.93 09/12/2012

Full log attached.

If someone is interested in the details about this patch, the creator has produced an article for that at [4].

[4]: http://trofi.github.io/posts/210-ptrace-and-accidental-boot-fix-on-ia64.html


I wrote "manually" above because I also stumbled upon that Ruby dependency Jason reported in [3] for kernel building. I assumed a temporary problem or a problem in my Debian installation. Wow, depending on Ruby to "build" a kernel the Debian way is a real show stopper. I hope this gets ditched soon...

[3]: https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=908519


Attachment: linux-4.17.17-with-gentoo-ia64-ptrace-patch-on-rx2800-i2.txt.gz
Description: application/gzip

Reply to: