[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: kernel in stable breaks gdb (on merulo)


I don't know what kind of information this can provide, if any, but here's it.

Working with Gentoo, I've hit the same issue with kernel 3.10.7. I
remembered having successfully ran gdb in the past, so tested all the
previous kernel versions I had before. I can go as old as kernel 3.3.8
(first kernel that I ran on Gentoo) and noticed that the gdb SIGTRAP
depends on the kernel configuration.

Indeed, I have a 3.3.8 kernel configuration for which gdb isn't
getting the SIGTRAP signal. Now, if I slightly alter this kernel
configuration by switching from module to in-kernel compiled either
ext4 filesystem or Radeon DRM, gdb doesn't work anymore. What's the
difference for a given feature w.r.t memory management or memory
layout being compiled in-kernel or as a module?

It's noteworthy that, from the working kernel configuration, if I add
a single other feature, like auditing support or cgroups support, or
PPP module, gdb doesn't work anymore.

I've also tested the working configuration for kernels 3.5.7,
3.5.7-r1, 3.7.10, 3.7.10-r1 and 3.8.13 without a success.

Any ideas/suggestions to go further?


2013/8/15 Émeric MASCHINO <emeric.maschino@gmail.com>:
> Hi,
> Just to let you know that, while kernel 3.9.8-1 was working fine, the
> "gdb stops with SIGTRAP at 0" bug is back with kernel 3.10.5-1 in
> today's "Jessie" Testing updates :-(
>      Émeric
> 2013/8/8 Ben Hutchings <ben@decadent.org.uk>:
>> On Wed, 2013-08-07 at 16:54 -0400, Camm Maguire wrote:
>>> Greetings!
>>> Stephen Gran <sgran@debian.org> writes:
>>> > Hi,
>>> >
>>> > This one time, at band camp, Patrick Baggett said:
>>> > > Hi Camm,
>>> > > On Thu, Jul 4, 2013 at 10:51 AM, Camm Maguire <camm@maguirefamily.org>wrote:
>>> > >
>>> > > > Greetings!  gdb stops with SIGTRAP at 0 on merulo, the sole debian ia64
>>> > > > porterbox.  This is a known bug fixed in later versions of the 3.2
>>> > > > kernel series:
>>> > > >
>>> > > > http://www.mail-archive.com/debian-ia64@lists.debian.org/msg03404.html
>>> > > >
>>> > > > For some reason we are having trouble upgrading the kernel in the stable
>>> > > > release, and debian-admin won't upgrade the merulo kernel without this.
>>> > > > What is blocking the progress here?
>>> > >
>>> >
>>> > I would have thought Camm should try, at a guess, the maintainers of
>>> > the kernel, as they should have something to do with uploads of the
>>> > kernel.  Maybe I've missed something, though.
>>> Indeed -- thanks!  By way of further information, I can report that Dann
>>> Frazier has tried the kernel package in stable on his machine and can
>>> use gdb without issue.  So would it be possible for the kernel
>>> maintainers listed above to determine why this bug, ostensibly fixed, is
>>> still present at merulo?
>> Not a clue.  Dann is the only kernel maintainer with responsibility for
>> ia64 and I'm not sure he has much opportunity to work on it any more.
>> I've just fixed occasional build failures; beyond that I don't know or
>> care about the platform.
>> Ben.
>> --
>> Ben Hutchings
>> The two most common things in the universe are hydrogen and stupidity.

Reply to: