[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: Wheezy kernel does not boot on HP zx6000

Hi Lennert,

lennert@vanalboom.org said:
> I also run a zx6000, but with HP-UX. When booting wheezy in an Integrity
> Virtual Machine on the zx6000, the VM crashes and dumps core - basically the VM
> equivalent of the red diagnostic leds that you see. I am also able to boot the
> squeeze kernel; it lacks storage drivers (those worked in 5.0.10, though...)
> but apart from that it looks good enough.
> On my VMs, I could not capture anything at all regarding what happens
> - either nothing is being spewed out, or I haven't found out where to get it.
> Serial at least doesn't show anything.

Would the kernel normally use a serial console when booting in an Integrity
VM, or does it go through an virtualized framebuffer?

I've never tried it, but Documentation/kernel-parameters.txt has this:

       earlycon=       [KNL] Output early console device and options.
                        Start an early, polled-mode console on the 8250/16550
                        UART at the specified I/O port or MMIO address.
                        MMIO inter-register address stride is either 8-bit
                        (mmio) or 32-bit (mmio32).
                        The options are the same as for ttyS, above.

My zx6000 shows the following serial ports on boot, so it's possible
setting earlycon= to one of these might give more information (you'll want
to cross check where the VM maps these ports):

        Serial: 8250/16550 driver, 4 ports, IRQ sharing enabled
        00:04: ttyS0 at MMIO 0xff5e0000 (irq = 49) is a 16550A
        00:05: ttyS1 at MMIO 0xff5e2000 (irq = 50) is a 16550A

> If you find out anything more, I'm most interested.

I'll try. Unfortunately I don't have much room for experimenting with the
machine since it is running some production services and I also only have
physical access to it during working hours. (I bought an MP board for it,
but could never get the console working on it.)

If you can easily try different kernels on your VM, maybe it would be worth
trying the normal -itanium kernel and possibly the kernels from unstable.

In any case, thank you for confirming that the problem exists; I'll go file
a bug in the BTS.



Attachment: signature.asc
Description: Digital signature

Reply to: