[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: Bug#711107: gtk+3.0: FTBFS on ia64 and mips

OK, I turned on my machine and re-ran the 'a11y/children' test.

It worked just fine under X and Xvfb when I ran it as just "./children" and "xvfb-run ./children" respectively -- I get OK messages like you wrote initially and no assertion failures.

Next I deleted the whole gtk+3.0 directory, redownloaded the source, and rebuilt it. I hit the same error:

WARNING **: Error retrieving accessibility bus address: org.freedesktop.DBus.Error.ServiceUnknown: The name org.a11y.Bus was not provided by any .service files

If anyone has an idea why running this before building gtk+3.0 is ok, but running it afterwards fails, I'd love to know. I can say that whatever the original problem (assertion failure in children.c) was, I didn't seem to run into it.


On Wed, Jun 12, 2013 at 10:17 AM, Emilio Pozuelo Monfort <pochu@debian.org> wrote:
On 12/06/13 16:48, Patrick Baggett wrote:
> Hi Emilio,
> I have an ia64 box with local graphics adapter and working X server. Pardon
> the newbie question -- do I use apt-get to pull the source and then build
> it using "make test" or some other procedure?

That's great! Something like this should work:

apt-get update
apt-get source gtk+3.0
apt-get build-dep gtk+3.0
cd gtk+3.0-3.8.2
dpkg-buildpackage -us -uc

At some point the build will fail (when running the tests). Then do:

cd debian/build/shared/tests/a11y


And see if the test passes. And

xvfb-run ./children

And see if it fails.


Reply to: