[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: ia64 porters still active?

On 02.05.2012 18:07, Patrick Baggett wrote:
> Matthias,
> I wouldn't mind helping a bit, as I'd like to see GCC 4.7 be the default on
> ia64. I'm good at C/C++ programming and can definitely provide upstream
> patches, but I have absolutely no idea what the "debian way" of doing
> things is -- right now, I'm an end-user. What can I do?

hi Patrick,

please have a look at the ia64 specific bug reports for the gcc-4.6 and gcc-4.7
sources. Then try to reproduce these using the available compiler versions (4.4,
to 4.7 and trunk/gcc-snapshot).  Get the preprocessed source, try to to produce
a smaller test case, which can be forwarded upstream, try to find out if it's a
regression compared to earlier gcc releases.

However I'm not sure to default ia64 to 4.7 unless you do have the resources and
skills to do a test rebuild on ia64 and forward or fix regressions for that change.


Reply to: