[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: ia32el package for Debian?

>>>>> On Thu, 27 Jan 2005 19:56:51 -0800, Randolph Chung <tausq@debian.org> said:

  Randolph> can you actually run qemu on ia64? it didn't work for me
  Randolph> when i tried last week.

You and me both (well, I tried a long time ago, but I did check and
there is no debian package for qemu on ia64 either).

  Randolph> is there any way to host an x86 kernel on an ia64 system
  Randolph> (using qemu, uml, or whatever...)

Well, there is bochs.  Last time I tried (long time ago), it didn't do
much on ia64.  I just tried again and, boy, it's pretty cool!

I just did:

	$ apt-get install bochs bochs-x

Then fetched a Linux diskimage from:


extracted it, cd'd into the directory and typed "bochs" and it booted
right into a single-user shell:

 # cat /proc/cpuinfo
 processor       : 0
 vendor_id       : GenuineIntel
 cpu family      : 5
 model           : 1
 model name      : Pentium 60/66
 stepping        : 3
 cpu MHz         : 15.000260
 fdiv_bug        : no
 hlt_bug         : no
 sep_bug         : no
 f00f_bug        : yes
 coma_bug        : no
 fpu             : yes
 fpu_exception   : yes
 cpuid level     : 1
 wp              : yes
 flags           : fpu tsc msr cx8 mmx
 bogomips        : 14.95



Reply to: