[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: Suddenly no X-window

I had to deal with a somewhat similar problem yesterday, though on an
x86 box. I had been running unstable which I updated last about a month
back. I installed abiword yesterday which brought in a few libraries
with it. Right after that I could not launch most apps. I logged out of
my session and now gdm wouldn't start any more. I updated to latest
unstable and that did not do anything.

I finally figured out I had libXrender in /usr/lib as well as in
/usr/X11R6/lib. I deleted the one under /usr/X11R6/lib, ran ldconfig and
voila gdm started working. I was able to launch all apps as before as
well. I have no idea which package did the libXrender under
/usr/X11R6/lib come from.

This may be a long shot, but check if you have the same problem.


On Thu, 2004-04-01 at 14:57, Richard Harke wrote:
> On Wednesday 31 March 2004 01:40 pm, Richard Harke wrote:
> > On Monday 29 March 2004 09:39 am, David Mosberger wrote:
> > > >>>>> On Mon, 29 Mar 2004 00:48:28 -0800, Richard Harke
> > > >>>>> <rharke@earthlink.net> said:
> > >
> > >   Richard> I see the NVIDIA logo then it tries to change but
> > >   Richard> immediately quits, that is it switches back to VGA terminal
> > >   Richard> mode
> > >
> > >   Richard> The lines I gave were from the messages on screen They were
> > >   Richard> not in XFree86.0.log because they are from KDE and not from
> > >   Richard> X Effectively, X only runs long enough for the Nvidia logo
> > >   Richard> to display
> I just tried startx as root and it worked, sort of. It came up with twm
> instead of kde but otherwise seems to be working correctly.
> So I conclude this either a Kde problem or a permissions problem.
> Does this suggest anything??
> Richard

Khalid Aziz                                Linux and Open Source Lab
(970)898-9214                                        Hewlett-Packard
khalid_aziz@hp.com                                  Fort Collins, CO

"The Linux kernel is subject to relentless development" 
				- Alessandro Rubini

Reply to: