[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: copypage.pl errors

On Fri, Oct 15, 2010 at 05:55:56PM +0200, Slavko wrote:
> i tried to start translation of the new slovak page, then i run as
> usually:
> ./copypage.pl english/doc/ddp.wml
> but i get this:
> Processing english/doc/ddp.wml...
> Use of uninitialized value $cvs_location in pattern match (m//) at ./copypage.pl line 363.
> ERROR: A translation already exist in CVS for this file.
> Please update your CVS copy using 'cvs update'.

Reading the code this is perfectly understandable because due to

> My working copy is updated. Some mins before i try the same for page
> english/banners/index.wml, without any problems...
> the cvs status for ddp.wml returns:
> cvs status slovak/doc/ddp.wml
> cvs status: nothing known about `slovak/doc/ddp.wml'
> ===================================================================
> File: no file ddp.wml           Status: Unknown
>    Working revision:    No entry for ddp.wml
>    Repository revision: No revision control file

not matching 
if ( $line =~ /Repository revision:\s+(\d+)\.(\d+)\s+(.*)$/ )  {
later on (line 363) the variable is undefined and the else branch is
matched. However, I don't understand the logic. I can only guess that
different CVS versions (from squeeze?) yield different output.

> please, can someone help me?

I CC'ed the developer of this code, it is relativly new so maybe buggy
or only tested in Squeeze. Are you using Stable?


      Dr. Helge Kreutzmann                     debian@helgefjell.de
           Dipl.-Phys.                   http://www.helgefjell.de/debian.php
        64bit GNU powered                     gpg signed mail preferred
           Help keep free software "libre": http://www.ffii.de/

Attachment: signature.asc
Description: Digital signature

Reply to: