[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: Troubles with updating Debian Hurd

Sergey Bugaev, le jeu. 30 sept. 2021 15:35:41 +0300, a ecrit:
> The issue with debootstrap, part 1
> ==================================
> To check if the previous issue is my system being in a messed up state, I've
> tried to bootstrap a subhurd, to check if everything would work cleanly
> there. Again, I've successfully used debootstrap to create subhurds on
> this same system before.
> The Hurd wiki page on subhurds [2] suggests the following command:
> debootstrap sid mnt/ http://httpredir.debian.org/debian
> [2]: https://www.gnu.org/software/hurd/hurd/subhurd.html

Please always check the latest version of the wiki pages on darnassus,
there it was fixed:

debootstrap --keyring=/usr/share/keyrings/debian-ports-archive-keyring.gpg --extra-suites=unreleased sid chroot http://deb.debian.org/debian-ports/

> W: Retrying failed download of
> http://snapshot.debian.org/archive/debian-ports/20210812T100000Z/pool-hurd-i386/main/g/gcc-10/libgcc-s1_10.2.1-6_hurd-i386.deb
> W: http://snapshot.debian.org/archive/debian-ports/20210812T100000Z/pool-hurd-i386/main/g/gcc-10/libgcc-s1_10.2.1-6_hurd-i386.deb
> was corrupt
> W: Couldn't download package libgcc-s1 (ver 10.2.1-6 arch hurd-i386)
> at http://snapshot.debian.org/archive/debian-ports/20210812T100000Z/pool-hurd-i386/main/g/gcc-10/libgcc-s1_10.2.1-6_hurd-i386.deb
> then later the same thing for libstdc++6; the rest of the packages get
> downloaded successfully and pass the validation.
> That surely looks like something's broken about the repos, and not in my
> system!

Yes, there were a couple of issues on that archive part, fixed later on,
and not a problem when using it to install from the CDs (which have
these packages already).

> The log contains the following:
> Processing triggers for libc-bin (2.32-4) ...
> Errors were encountered while processing:
>  rsyslog
> dpkg: dependency problems prevent configuration of rsyslog:
>  rsyslog depends on libjson-c3 (>= 0.10); however:
>   Package libjson-c3 is not installed.

Yes, that's why you need the unreleased part.


Reply to: