[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Bug#805441: abi-compliance-checker no longer works on hurd

Package: abi-compliance-checker
Version: 1.99.11-1
Severity: important
Control: affects -1 davix
X-Debbugs-Cc: debian-hurd@lists.debian.org

A recent binnmu of davix 0.4.1-2+b1 failed on hurd due to abi-


This build used abi-compliance-checker 1.99.11-1, and the error is:

cd /«PKGBUILDDIR»/obj-i586-gnu/dist && abi/check_abi.sh
Generate  new ABI dump....
ERROR: can't check ARCH type

The original build of davix 0.4.1-2 worked fine on hurd


This build used abi-compliance-checker 1.99.9-2, and the log says:

cd /«PKGBUILDDIR»/obj-i586-gnu/dist && abi/check_abi.sh
Generate  new ABI dump....
Using GCC 5.2.1 (i586-gnu)
checking header(s) 0.4.1 ...
WARNING: can't find 'ctags' program
creating library ABI dump ...
library ABI has been dumped to:
you can transfer this dump everywhere and use instead of the 0.4.1
version descriptor
Compare to previous ABI dump
Finish !

Retrying the build on a porter box with the latest abi-compliance-
checker 1.99.14-1 gives the same error.

Running the check using the old abi-compliance-checker 1.99.9-2 on the
porter box still works. But you can of course not use that trick on a


Attachment: signature.asc
Description: This is a digitally signed message part

Reply to: