[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Problems with crosshurd (was: Ethernet drivers for GNU Mach)

On Sat, 2 Apr 2011 14:01:31 +0200
Samuel Thibault <sthibault@debian.org> wrote:

> That's it then: that didn't transfer the translator entries.

Ahh, okay. Thanks for the advice.

I've now set up a Hurd installation using crosshurd 1.7.42 from Debian
GNU/kFreeBSD (sid), but have come across the following problems:

* crosshurd didn't install a kernel (I've copied GNU Mach across from
my qemu image, so this is no longer a problem)
* /dev is empty except for MAKEDEV, which returns 'Pipe call failed' on
line 10 if I try to run it
* trying to run /native-install fails at trying to write
to /etc/passwd, saying it's on a read-only filesystem (I can't use
settrans to fix this because there's nothing in /dev, as above)

The above problems occur whether or not I use single-user mode (passing
-s to GNU Mach), and whether or not I run 'export TERM=mach' first.

My gut feeling tells me these three things are probably related to a
common cause, but I don't know enough about crosshurd to know what that
might be. Crosshurd didn't return an error when I ran it, it just
doesn't seem to have created a usable Hurd system.

Has anyone seen the above errors before, or does anyone know what the
cause might be?

Attachment: signature.asc
Description: PGP signature

Reply to: