[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Java in Hurd


Can we use Java in Hurd now?

I failed to install kaffe with apt-install. Here is the error:

The following packages have unmet dependencies:
 kaffe: Depends: kaffe-pthreads (>= 2:1.1.8-5) but it is not installable or
                 kaffe-jthreads (>= 2:1.1.8-5) but it is not installable
E: Broken packages

So I tried to compile it by myself. I install a Java compiler jikes and a bunch of libraries required by kaffe. I did compile kaffe with jthreads successfully, but I still cannot run the Java program.

(null):~/tmp# java Test
Internal error: caught an unexpected exception.
Please check your CLASSPATH and your installation.
java/lang/UnsatisfiedLinkError: Native library `javanio' not found (as file `libjavanio.so' in class loader null) in gnu.classpath.boot.library.path and java.library.path `[/usr/local/kaffe/jre/lib/i386/, /usr/local/kaffe/lib/, /usr/share/classpath//lib/classpath/, /X11R6/lib/]'
  at java.lang.ClassLoader.getSystemClassLoader (ClassLoader.java:799)

So I tried to install classpath. I couldn't install it with apt-get. Here is the error:

(null):~/tmp# apt-get install classpath
Reading package lists... Done
Building dependency tree Reading state information... Done
Package classpath is not available, but is referred to by another package.
This may mean that the package is missing, has been obsoleted, or
is only available from another source
However the following packages replace it:
E: Package classpath has no installation candidate

Again, I tried to compile it myself. However, I was not lucky this time.
In order to compile classpath, I installed gtk+-2.0, libgconf2 and some other libraries. However, I still couldn't compile it.
Here is the problem when I tried to configure it:

configure:29654: checking for javac
configure:29670: found /usr/bin/javac
configure:29681: result: javac -Xlint:unchecked
configure:29741: checking if javac -Xlint:unchecked works
configure:29761: javac -Xlint:unchecked  -source 1.5 -target 1.5 Object.java
Error: The option "-Xlint:unchecked" is unsupported in this build.
configure:29764: $? = 2
configure:29768: error: The Java compiler javac -Xlint:unchecked failed (see config.log, check the CLASSPATH?)

It seems that jikes doesn't support -Xlint:unchecked and I suppose gcj supports it, but I don't know how to install gcj. I cannot install it with apt-get. Do I have to download the whole gcc source code and compile it?

I searched for Java and Hurd with google, and did see some discussion about it, but they are all 10 years ago. I hope a lot of things have changed in the past 10 years. Is there any easy way to install jvm and the compiler in Hurd?

Zheng Da

Reply to: