[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: make libc0.3-dev depend on hurd-dev or something?

On Sun, Dec 16, 2007 at 12:44:49AM +0000, Samuel Thibault wrote:
> I've just got a package build failure because on hurd-i386, the
> libpthread.so symlink is provided by hurd-dev, which is not in the
> build-deps of the package since libpthread.so is usually provided by
> libc6-dev.  Should libc0.3-dev depend on hurd-dev, or should we just
> make build-essential depend on hurd-dev?

Entangling the core dependencies even more might give trouble during
upgrades (see the TLS transition), so just adding hurd-dev to
build-essential might be better.  I thought it was already, at least I
make sure the buildd has it installed in the chroot.


Reply to: