[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: Can't get vim installed...

On Nov 20, 2007 6:46 PM, Javier Vasquez <jevv.cr@gmail.com> wrote:
> Hi,
> When trying to install "vim":
> # apt-get install vim
> ...
>    vim:  Depends:  vim-runtime (= 1:7.1-022+1) but 1:7.1-138+1 is to
> be installed.
> I instead installed vim-tiny, but it's ugly since I can't get "syntax
> on" working.  I even tried modifying
> /var/cache/apt/lists/debian.osuosl.org_debian_dists_unstable_main_binary-hurd-i386_Packages,
> to see if I could modify the dependency, but I got no luck, since the
> changes I made don't seem to take effect, and the same error shows up.
>  I also tried apt-get install -f vim, but it doesn't work (no
> surprise, since I've tried that on debian-linux unstable
> unsuccessfully as well).
> So I can't get the editor I'm fond of, to work...  Any work around?  My repos:
> http://www.superunprivileged.org  <==    unreleased mirror
> http://www.debian.osuosl.org         <==   unstable mirror
> Thanks,
> --
> Javier

BTW, I also tried manually downloading the package, and then doing
"dpkg --force-all -i vim", and it worked.  But I had to remove it
since, if I keep vim then apt-get breaks due to the dependency
problem, :(, so if some one was thinking about this possible work
around, it doesn't work out well....


Reply to: