[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: cross-debootstraped rootfs is failing to boot

2007/9/30, Thomas Schwinge <tschwinge@gnu.org>:
> The file system you are booting from indeed has to be a ``Hurd'' one, but
> the one you run `debootstrap' one needn't, as no passive translators are
> being set-up during that process.

OK. So my first setup was OK.
> > Now as per your suggestion I copied /servers/exec from another
> > installation (K14) and it proceeded
> `touch'ing it would have been enough.

OK. Hope this will be taken care of in debootstrap.
> > failed saying /dev/console not found.
> >
> > I copied /dev/console also from my other installation it failed with
> > error Read only filesystem.
> Copying won't work as it's a passive translator setting (which is
> currently not accessible from Linux-based systems).  Does your Hurd file
> system have an (empty) `/tmp' directory?  A fallback console should
> automatically be created in there during the boot process, as long as the
> passive translators inside `/dev/' haven't been set-up.  Please try this:
> #v+
> $ cd [...]
> $ rm dev/console
> $ mkdir tmp
> $ chmod 01777 tmp
> #v-
> If a `/tmp' directory already did exist, then please show the complete
> messages.

It had a /tmp directory with console file. But I deleted the directory
and followed your instructions wrt permissions.

It still had the same error.

The complete error message is given below:

start /hurd/ext2fs.static: ext2fs: device:hd0s3: warning: FILESYSTEM

(well I did fsck and this message was gone)

Hurd server bootstrap: ext2fs.static [device:hd0s3] exec init proc
auth/libexec/console-run: /dev/console: No such file or directory
/libexec/console-run: /tmp/console: Read-only filesystem
/libexec/console-run: /hurd/term: Read-only filesystem
/libexec/console-run: using temporary console /tmp
/libexec/console-run: cannot execute /libexec/runsystem
No such file or directory

(this indeed was the probelm /libexec contained runsystem.gnu after
renaming it to runsystem it booted correctly)

/hurd/init: /libexec/runsystem exited with status 5
/libexec/console-run: /dev/console: No such file or directory
/libexec/console-run: /tmp/console: Not a directory
/libexec/console-run: /tmp: Device or resource busy
/hurd/init: /bin/sh exited with status 2

(this sequence repeats once more)

So the renaming of runsystem.gnu to runsystem in /libexec solved the
issue. I hope this will also be taken care in next version.

uname -a, ls and other commands are working

but each of these gives out one warning

sh: start-pipeline: pgrppipe: Protocol family not supported

Thanks Thomas for the help.

Happy Hacking

പ്രവീണ് അരിമ്പ്രത്തൊടിയില്
Join The DRM Elimination Crew Now!

Reply to: