[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: locales-all failing to install


On Thu, Aug 02, 2007 at 12:26:20PM +0200, I wrote:
> I think this problem is already known, but I'm not sure, so I post about
> it here:
> #v+
> $ sudo apt-get install locales-all
> [...]
> Unpacking locales-all (from .../locales-all_2.5-11+hurd.1_hurd-i386.deb) ...
> Setting up locales-all (2.5-11+hurd.1) ...
> [Busy for some minutes on this slow machine...]
> cannot lock new archive: Operation canceled
> dpkg: error processing locales-all (--configure):
>  subprocess post-installation script returned error exit status 1
> Errors were encountered while processing:
>  locales-all
> E: Sub-process /usr/bin/dpkg returned an error code (1)
> #v-
> Nevertheless, locales seem to work even in this half-installed state.

Those of them worked that had already been built until it stopped.  They
are built alphabetically and it stopped somwhere around `es_*'.

Another thing: when I just upgraded Barry's `shitbox' to the version
2.6.1-1 glibc packages, which also included upgrading the `locales-all'
package, then upgrading the latter one worked without the locking error
quoted above.  Have there been any changes in that area?

$ locale -a | sed -n '1,4p;5s%.*%...%p;$p'


Attachment: signature.asc
Description: Digital signature

Reply to: