[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Not accessing network after apparently succesful settrans of the /hurd/pfinet


After not being able to use the ethernet device of my laptop, I
decided to try out a friend's box after a crosshurd installation.

When performing "cat /dev/klog" I get:

eth0: VIA VT6105LOM Rhine-III (3106) at 0xd000, (MISSING EEPROM
ADDRESS)3e:4c:69:6e:75:78, IRQ 10.
eth0: MII PHY found at address 1, status 0x786d advertising 5e1 Link 45e1.

Apparently the ethernet card was recognized...  Then as the network
access comes from DHCP server, I used work around indicated under:


So then I tried:

settrans -fgcap /servers/socket/2 /hurd/pfinet -i eth0 -a
<assigned_ip> -m -g <dhcp_server_ip>

And it worked out without errors, so that after "ps auxww | grep pfinet" I get:

root  90  0.0  0.3  131M  1.44M  -  So  7:42PM  0:00.03  /hurd/pfinet 
-i eth0  -a <assigned_ip>  -m  -g <dhcp_server_ip>

However after performing "ping <dhcp_server_ip>" the console just
hangs forever.  In case "ping" was not working properly I also tried
"apt-get update", and it also hangs forever.  I looked at the card
leds, and although it's powered, it experiences no activity...

Just in case I also tried removing "-a", "-m" and "-g" options and
using instead just "-d", in case dhcp was working, but the effect is
exactly the same, the console just hangs forever.

In the case of "ping" I also tried "-c2" but that option doesn't help...

So, it looks like the card is recognized properly, but I need error
messages to detect what's wrong.  Any hints?  What are the next steps
to enable the ethernet card?


Javier-Elias Vasquez-Vivas

Reply to: