[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

netdb.h problem?


I tried to compile latest release of tcsh on hurd, and out of the box
I got the following error:

ma.setp.c: 138: error: conflicting types for 'rcmd'
/usr/include/netdb.h: 499: error: previous declaration of 'rcmd'
make: ***[ma.setp.o] Error 1

The error refers to a function (rcmd) declared in netdb.h with 6
parameters, and a function defined in ma.setp.c (rcmd) with just 1

To solve the compilation problem I tried moving /usr/include/netdb.h
somewhere else, but apparently the header is required, so that didn't
work.  Then I just commented out the function declaration under
netdb.h, and compilation succeded...

Is this just a declaration that shouldn't be there?  I noticed a
comment about it under netdb.h:

/* ... This function is not part of POSIX and therefore no official
cancellation point.  But due to similarity with an POSIX interface or
due to the implementation it is a cancellation point and therefore not
marked with __THROW. */

Should it be removed and nothing else would break?  For safety I just
uncommented back the function declaration, however I'm thinking due to
the comment that maybe it should be removed...  If so, would this be a

Any ways, the problem I had at hand was solved.  I'm happily using
tcsh (thankfully) under hurd...


Javier-Elias Vasquez-Vivas

Reply to: