[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: XFree86...

On Mon, Jul 19, 2004 at 12:59:34PM -0700, Simon La Rose wrote:
> I recently installed XFree86 onto Debian GNU/HURD .03 /  
> GNUmach-1.2 and am having troubles with xroot and fluxbox running. X loads up, and I get the 
> xroot (checkerbox bg) with an uber weird `cat /dev/urandom`-type square in 
> the middle of the screen. 

Hmm, dunno what that could be.

> I've got "exec fluxbox" in my .Xinitrc file, but still nothing
> happens. 

Although I've heard people talking about fluxbox, I've never tried it
myself. Best thing for testing is probably having just 'exec xterm' in
your ~/.xinitrc (btw, I'm not sure the bix 'X' is really ok, you better
try both ways)

> Since I'm writing this, I might as well mention that I can't get the
> screen (bindkeys) solution to work for virtual consoles, 

I haven't tried screen lately, either, sorry. Perhaps somebody else can
share his observations.

> nor can I find the new-console deb for Hurd. 

The new console has been shipped with the hurd packages for a while,
it just does not get started by default. If you use the lastest hurd
package from ftp.debian.org (or another debian mirror), you should be
able to startup the Hurd console by running something like this as root:

console -d vga -d pc_kbd --repeat=/dev/kbd -d generic_speaker /dev/vcs

Hope that helps a bit,


Reply to: