[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: Network device

Thanks alot!

Michael Banck wrote:

I couldn't find the tulip driver in the cvs-version, or a howto for integration the kernel network device driver. Is anywhere a precompiled mach kernel with tulip support?

I don't understand you completely I believe.

The current Debian package on ftp.debian.org (version 20040229) has
tulip.c in its source and --enable-tulip in it's configure line, so I
assume that it is included. The source package is also quite identical
to the current gnumach-1-branch of GNU Mach in CVS.

So I think, I had "wrong" sources. Now I tried the sources from ftp.debian.org, see below.

tulip.c:v0.91g-ppc 7/16/99 becker@cesdis.gsfc.nasa.gov
eth0: Digital DS21143 Tulip rev 65 at 0xd000, 00:00:1C:B0:67:EA, IRQ 10.
eth0:  EEPROM default media type Autosense.
eth0:  Index #0 - Media MII (#11) described by a 21142 MII PHY(3) block.
eth0:  MII transceiver #8 config 3100 status 782d advertising 01e1.

Yeah, this is the version string of the current driver in GNU Mach 1.x
and it seems that your card gets detected.

AMS has whipped together a patch with the latest drivers from Donald
Becker, you can find his announcement with a link to the patch at


Maybe those drivers work better for you, please report back if you try
these out, they need testing.

I tried the sources from ftp.debian.org with and without this patch, compiled on the native and a Linux system, and got the following results:

without patch on native: kernel halt as earlier
with patch on native: doesn't compile. stops with AC_... something not defined (I will try to reproduce this)

with patch on Linux: seems to work.

Maybe I will return with bug reports ;-)

Best wishes            Jan

Reply to: