[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

install report

Hi all,

I just came from installing the hurd and I thought I'd report my
progress.  I formatted some partitions, one for /, /boot, /var and
/home, mounted them under linux and untarred gnu-20020816.tar.gz.  I
booted single user and ran native-install without any problems,
rebooted, set the translators for the extra partitions and ran
native-install again.  dpkg threw up lots of warnings/errors but it got
through it.  I got a message

"WOAH! We're in deep trouble.  The Hurd package did not
update the link in /libexec/runsystem.  For now, I am making a link
manually, but please report this."

After that finished, I ran 'dpkg --configure -a' and it configured a
number of packages, including hurd.  Rebooting into multi-user mode
worked fine.  There were some problems with dpkg; namely debconf not
having any frontends available.  It complained about a lack of
Term/Readline.pm.  I installed dialog and it used that fine.

I then tried to install X but, for some strange reason, xbase-clients
(at least Mr Nilsson's version) depends on cpp and apt didn't know
anything about the required version so I installed the dependencies by
hand (from a K2 CD) and eventually got X on there.  After a lot of
toiling with XF86Config-4, I eventually got the X server to come up but
it wouldn't run as a user, reporting

"X: user not authorized to run the x server, aborting."

I editted /etc/X11/Xwrapper.config to change the allowed_users setting
from "console" to "anybody" and this fixed it.  I can run startx as a
user now and it will bring up twm or fvwm or whatever.  Unfortunately,
I've been unable to get rxvt to run from an editted twm menu or an
example fvwm2rc.  I created a script, /usr/bin/terminal:

export DISPLAY=:0.0
export TERM=mach-color
export PATH=/bin:/X11R6/bin:/local/bin

and tried to run that from the twm menu, but still to no avail.  This is
where I'm up to now.  Can anybody shed some light on how I can get a
terminal running in X?



Bob Ham <rah@bash.sh>

Attachment: signature.asc
Description: This is a digitally signed message part

Reply to: