[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

New install problem and what worked for me



Hi all,

I just installed debian hurd yesterday for the first time and
with some patience got it to work properly using the install guide.
One little snag I had was that the version of e2fsprogs that comes
with the install was too old (or at leasst that's what it told me).  I
created the partition from linux with 'mke2fs -o hurd /dev/sdb1' as
instructed in the install guide with e2fsprogs v1.29.  I installed the
base system from the gnu-latest.tar.gz that was available.

All seemed to go well during the install until I tried to boot into
multi-user mode, where fsck would die, at first telling me to upgrade
my tools.  So after a bit of work I built e2fsprogs 1.29 under hurd,
uninstalled the old package and reinstalled the new one and everything
worked fine.  I still get an error message when first running e2fsck
about an unknown return code and not knowing if the partition is
mounted (sorry, I don't have the exact text...I was going to try and
hurt this bug down myself once I get the kernel building). 

The next problem came when I tried to reboot.  It seems that the
options used in /libexec/rc (/sbin/fsck --preen --writable) are a bit
odd.  I don't see either --preen or --writable as available options in
the manpage, so I changed them to -p and it all seemed to work ok and
booted into multi-user mode fine.

After this, everything worked pretty well, but it still seems like
there's a lot of work to be done (which is why I'm trying out
gnumach/hurd, since I wasn't to be able to actually contribute
something :)  but seems at the verge of being actually usable.  It was
a pleasant suprize and I'm sure you'll be getting more questions and
code from me soon.

burton

Attachment: pgpT6cpRTgPtB.pgp
Description: PGP signature


Reply to: