[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Some feedback on Hurd-F2

Dear * .*,

I just tried out the Hurd-F2 CDs and would like to give some feedback. I
hope that this is the appropriate place.

First, there has been some discussion here on the list concerning exim.
Indeed, exim did not install at first. Apt-get complained that it could
not find libpcre2. However, after I compiled and installed libpcre2 from
my potato source CDs, exim installed without further errors. So I guess,
this library should be included in future Hurd CDs.

Second, I wonder, why rxvt is missing on the CDs. I grabbed the sources
from the unstable tree. As far as I can see, they compiled and installed
normally on my machine.

Third, I couldn't find a way to run any terminal emulator as non-root. I
have learned that for security reasons SUID and SGID programs ignore
LD_LIBRARY_PATH, and therefore are unable to locate the X11 libs. xterm
is SUID and rxvt is SGID. So, if I got it right, both won't run as
non-root. Late last year I installed Debian GNU/HURD and X11 from the
CDs distributed with the German magazine freeX. For some reason, then
both xterm and rxvt *did* work as non-root. Now, they don't. So
something must have changed since. Am I missing something important, or
is there really no way for non-root users to run a terminal emulator
under GNU/HURD?

Third, there were some dependency probs with Xfonts packages and xutils:
xfonts-base, xfonts-75dpi, xfonts-100dpi and xfonts-scalable require
xutils >= 4.0.3, but the version on the CD is 4.0.3
After compiling the xutils source package from Debian's ftp server, the
fonts packages did install normally.

Finally, concerning the mouse under X I tried to follow the instructions
from Marcus' freeX article (settrans -c /dev/mouse /hurd/mouse
-protocol=microsoft -device=com0). In XF86Config I set protocol to
"osmouse" and device to "com0". However, X would crash informing me
about a failure to initialize a core device. With the conventional
settings (device=com0, protocol=microsoft), X starts up normally,
although mouse movements are somewhat retarded.

Hope, these remarks are not completely useless.



Reply to: