[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: dpkg problem installing apache-common

Neil Levine <levine@yoyo.org> writes:

> It complains about the PERL package not being installed. So I install
> (also with dpkg) perl-5.005-base_5.005.03-7.1.deb with no errors. But
> when running the above command again I still get:
> dpkg: dependency problems prevent configuration of apache-common:
>  apache-common depends on perl; however:
>   Package perl is not installed.

All I know is that this package is old. "perl-5.005-base" is at version
6.1 ... but that is only a transitional package. The real thing is in
the package "perl" (version 5.6.0-21, currently).

> On a (perhaps) similar note, I have installed libc0.2-dev_2.2-3.deb,
> again with no errors, but see that the symlinks for the libc files
> havent changed from the install-time versions:
> -rwxr-xr-x    1 root     root      1235624 Jul 19  2000
> /lib/libc-2.1.3.so
> -rw-r--r--    1 root     root          190 Nov 25 02:26 /lib/libc.a
> -rw-r--r--    1 root     root          182 Nov 25 02:28 /lib/libc.so
> lrwxrwxrwx    1 root     root           13 Feb 13 22:22
> /lib/libc.so.0.2 -> libc-2.1.3.so

Of the above files, only libc.a and libc.so are in the "libc0.2-dev"
package. The shared library itself is in "libc0.2". The symlink is
(re)generated by "ldconfig", if I'm not mistaken.


Attachment: signature.ng
Description: PGP signature

Reply to: