[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: missing "shutdown" command, substitutes?

On Mit, Jan 03, 2001 at 07:05:39 +0100, Marcus Brinkmann wrote:
> > Both commands are no substitutes for the "shutdown" command since
> > they only constitute the final part of "shutdown".  This is obvious
> > because after each reboot with "reboot" one gets "Filesystem not
> > cleanly unmounted..." and a fs check is done.
> Not for me, and it should really work the way it is now.

I have experienced the same as Martin. Sometimes Hurd does unmount its
root device properly, but half the time it doesn't.
BTW: Does anybody know, when Hurd will come with PPP support? Since I
have only a dialup connection, I'm really looking forward to it.

Yet another feature, that I'm waiting for is a proper terminal server
with multiple virtual consoles. Any idea, when such will be implemented?

I've installed Debian GNU/Hurd from the freeX CDs. I also added the X
packages recently. One thing that didn't work out for me was using the
"osmouse". Following Markus' instructions in his article I added a mouse
device in the /dev dir. I have a three button mouse that uses the
MouseSystems protocol. 

(settrans /dev/com0 /hurd/mouse --protocol=mousesystems ..)

Then I modified the "pointer" section in XF86Config, telling X to use
the protocol "osmouse" and device "/dev/mouse".

With these setting the X server crashed immediately, informing me it was
"unable to initialize core devices".

Later on I tried the traditional X settings:

Section "Pointer"
   Protocol        "MouseSystems"
   Device          "/dev/mouse"
   BaudRate        1200
   Resolution      100
   Buttons         3

And this worked perfectly for me.

Is it, maybe, that Hurd's mouse server doesn't support all common mouse
protocols yet? 

Another prob: I have a Iomega parport 100 MB Zip drive connected to my
machine which is in return connected to a HP LaserJet printer. For some
unknown reason the printer doesn't print under GNU/Linux when the BIOS
parport mode is set to EPP. That's why I changed the setting to SPP. But
with this setting GNU/Hurd crashes with a Kernel panic after trying to
initialize the Zip drive. So, before booting GNU/Hurd I always have to
adjust the parport settings. Since I'm not a kernel hacker, I've got no
idea what's wrong here. Is this a known bug/feature?



Reply to: