[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Post-install exit status 137 in upgrading libc0.2 on fresh Hurd install.


I freshly installed my Hurd (running in VMWare) from the newest tarball from
alpha.gnu.org, and copied the latest base files from 
to the disk.  

When I attempt to dpkg -i /debs/libc0.2_2.2-3.deb, I receive the following

Setting up libc0.2 (2.2-3) ...
Checking for services that may need to be restarted...
/dev/fd/6: runlevel: command not found
dpkg: error processing libc0.2 (--install):
 subprocess post-installation script returned error exit status 137

A search on debian.org shows that /sbin/runlevel belongs to base/sysvinit,
which to my understanding does not exist (yet) for the hurd.  Ive tried
to work around the problem by creating my own /sbin/runlevel that is just
an empty script, the runlevel compliant goes away, but I still get the
post install error (so it seems to be unrelated).  

Ive reinstalled a few times thinking that there might have been a glitch,
but I get the same error.

Searches for exit status 137 came up with nothing, so I dont know where
to proceed from here.  any ideas?
 - Michael Oberg

Reply to: