[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Strange behaviour after cross-compiling


I cross-compiled glibc and the Hurd and installed them over Marcus'
freeX Hurd distribution. Strange behaviour results:

1. gnumach from CVS can't do color display (that's okay, but
   I'd like to know how the freeX gnumach.gz was generated!).
2. passwords are displayed on screen; every command is
   also echoed after being submitted.
3. commands can be used as usual (e.g. ls works etc...),
   but as soon as non-dumb screen capabilities are needed
   (including pipes!), I get the following error message:

bash [36: 1] tcsetattr: (ipc/mig) server type check failure

The error is not only from bash, but from other programs as well,
e.g. vi:

ex/vi: Error: tcsetattr: (ipc/mig) server type check failure

Every time this error occurs, the program is stopped by bash
and resuming it with 'fg' results in the same error again.

I tried to set TERM from mach-color to dumb, but the error

What's going on?

P.S.: I'm running the Hurd on a ufs (FreeBSD ffs) partition
mounted with ufs.static.



Farid Hajji -- Unix Systems and Network Admin | Phone: +49-2131-67-555
Broicherdorfstr. 83, D-41564 Kaarst, Germany  | farid.hajji@ob.kamp.net
- - - - - - - - - - - - - - - - - - - - - - - + - - - - - - - - - - - -
Murphy's Law fails only when you try to demonstrate it, and thus succeeds.

Reply to: