[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Palm with the Hurd


I tried to compile the pilot-link for the Hurd. It compiled well, except for
those parts which try to syncronize over the network (pi-csd and pi-nredir).
They need /include/net/if.h, which is not present on my Hurd, and
/include/netinet/if.h obviously can not replace it. (Warning: I do not know,
what I am talking about).

After building, I tried to connect through /dev/com0. It listed the contents
of the Palm, but was not able to synchronise.

	Backing up '...' ... Failed

And the error message:

	Tty 294a40 was stuck

came around, but vanishes after switching to another screen.

The following problems were found with gdb:

	fetch inferior registers: 4: Invalid thread
	fetch inferior registers: 4: Invalid thread

I am using the 1.2-7 gnumach (is this the one that can translate between Marcus
and his modem?). Although I do not have a single idea, what this all mean, I
think that 1) the line is capable to transmit a small amount of data, but can
not deal with a 'lot', 2) I needed to debug Mach, which I can not.

Any idea?


Reply to: