[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Bus error during c++ link, where is the error?


I ran into a bus error when I tried to compile flick on the Hurd. I can't
seem to think of a good method to track down the problem; I assume the
problem is not with gcc itself. Gdb trace below, gdb started as "gdb
/usr/bin/c++". I can't seem to make gdb catch the signal and give me a
stack frame regardless of the setting of "follow-fork-mode". Any advice
would be appreciated.

Current directory is /usr/bin/
GNU gdb 4.18
Copyright 1998 Free Software Foundation, Inc.
GDB is free software, covered by the GNU General Public License, and you
welcome to change it and/or distribute copies of it under certain
Type "show copying" to see the conditions.
There is absolutely no warranty for GDB.  Type "show warranty" for
This GDB was configured as "i386-unknown-gnu0.2"...
(no debugging symbols found)...
(gdb) cd /linux/usr/local/src/flux/flick-obj/c/pbe/fluke
Working directory /linux/usr/local/src/flux/flick-obj/c/pbe/fluke.
(gdb) source ../../../../flick-compile-args
(gdb) show args
Argument list to give program being debugged when it is started is
    "-L../../../lib -o flick-c-pbe-fluke        bcopy_opts.o client.o
mapping_sid.o fluke_target_mu_mapping_reference.o get_prim_params.o
ace_graph.o marshal.o misc.o mu_array.o mu_make_client_mu_state.o
t_mu_state.o mu_mapping_reference.o mu_server_func_reply.o
t.o server.o -lflick-c-pbe -lflick-pres_c -lflick-cast -lflick-compiler
-aoi -lflick-mint -lnsl ".
(gdb) run
Starting program: /usr/bin/c++ -L../../../lib -o flick-c-pbe-fluke
pts.o client.o fluke_mu_mapping_sid.o fluke_target_mu_mapping_reference.o
rim_params.o make_interface_graph.o marshal.o misc.o mu_array.o
mu_state.o mu_make_target_mu_state.o mu_mapping_reference.o
y.o mu_server_func_target.o server.o -lflick-c-pbe -lflick-pres_c
-lflick-cast \
-lflick-compiler -lflick-aoi -lflick-mint -lnsl
[Switching to thread 226.3]
[Switching to thread 226.4]
(no debugging symbols found)...(no debugging symbols found)...
collect2: ld terminated with signal 10 [Bus error]
(no debugging symbols found)...(no debugging symbols found)...
Program exited with code 01.
(gdb) bt
No stack.

Reply to: