[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: Hurd on my i486 won't boot

In article <[🔎] 86pv60azt5.fsf@trick.fig.org> you write:
>>>>>> Adam Sampson writes:
> AS> I then do:
> AS> root=(hd0,2)
> AS> kernel=/boot/gnumach root=hd0s3 -s
> AS> module=/boot/serverboot
> AS> boot
> >> > After this, my Num Lock light goes off and everything freezes;
> >> > it doesn't try to read from the hard disk.
>If you don't see any gnumach messages, then it's probably a GRUB bug.
>If you know how to make your own boot floppy, I suggest you try making
>one from the latest Debian GRUB package.  Otherwise, feel free to wait
>for a few days, when I'll be able to release new boot floppies that
>use the latest GRUB.

Ok, this has spurred me to write up the following.. any suggestions

I've been having terrible trouble with grub over the last few days,
in the the process of wanting to get the hurd up and running.

First of all, I tried compiling it (0.5.90 or so) on an old redhat 5.1,
and on an older debian hamm. Both of these compiled to non-functional
code, but with no warning!

Eventually, I downloaded the just released debian 2.1 whatever, and
that compiles it up to something thats the same as in the debian
packaged version, which I had found.

Anyway, once I had a grub that booted off a floppy, I thought that
I would convert my existing lilo setup to use grub exclusively.

I had about 20 lilo configs or so, and a few replaces later they were
in suitable format for grub. However, my 0.5.90 doesn't seem to
properly scroll the screen when one moves off the bottom of the list
of visible configs. Is this a known bug, is it fixed in later
versions? Just how working is this thing supposed to be anyway?

I was also fooled for a few minutes because a grub menu entry that
does an install is never the less reported as Failed, presumeable
because it didn't actually boot anything.

Anyway, forgetting that, the first thing I did was put it on the
beginning of a partition, loading a stage2 from that partition, and
that works fine with it being chainloaded from lilo.

I then thought I would put it on the mbr of the hard disk, and use a
stage1_5 in the spare 63 sectors at the beginning, so it didn't have
any sector list dependencies at all. Its a pity the stage2 has grown
so large - it would be nice if there was a stripped down version that
fit in 63 sectors, say without ffs filesystem or something.

I made this work, at least as far as getting to the grub command line,
but not with loading the config file properly however much I tried,
but all that only when it it was chainloaded from another grub booted
off floppy. It refuses point blank to work at all when booted from the
bios. I get no error messages, nothing, just a permanently on hdd
light. I have tried messing with the configured in drive numbers in
the headers, trying to hard code them to the hard disk. Is it supposed
to work as the primary boot method at all then?

If people tell me that they have this sort of thing working, I'll have
a shot at a little bit of debugging, somehow. (Presumeably instrument
code to put out gribbles on screen) Or maybe at least write down what
sort of bios I have so I can tell you about it.

so questions:

(1) Scrolling extra menu entries supposed to work?
(2) How to config a stage2 to find menu file after a stage1.5
(3) Why won't mbr installation work?

Reply to: