[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: lifimage boot issues

On 7/30/13 12:36 AM, Helge Deller wrote:
Hi Dave,

On 07/30/2013 06:39 AM, Dave Land wrote:
OK, humor me... I managed to burn the lifimage from the site to CD
and in the boot config list, there is an entry #2 - ip=bootp. How do
I change this to point to the CD as the image source? If I set the
proper kernel, it WILL boot, but it gets to a point where it's
looking for a bootp (tftp host, I'm guessing). This entry was never
in the Lenny net-boot discs, so I'm at a bit of a loss here, and
there doesn't seem to be anything in the documentation about it. If I
change that entry to anything else (i.e. 'local',, etc.),
it errors out and says 'Couldn't grok your kernel executable
formatERROR: failed to load kernel'. I'd really like to get this
machine back up and running at some point. A little help, please? I
don't have another machine on my network that I can do tftp from, so
that idea is out. Anybody have any ideas, solution, etc.? Thanks.

BTW, I'm working with a J6750 workstation (SMP 64 bit)...

What happens if you say Y to "interact with IPL", then enter "2" to
change the "ip=bootp" option, then just delete this value (press backspace
until the line is gone), and press enter.
If you do it like this, the "ip=bootp" option should be gone.
Then you can just continue the boot with "b".

I always select Y to "interact with IPL" in order to change to the proper kernel for 64 bit. I actually did try just removing the "ip=bootip" option, like you said, but got the same error message.

I just woke up a while ago, so I haven't had a chance to do any more testing today. :)

I haven't had a chance to actually test the lifimage from CD, I only
tested from tftp where it worked. Your J6750 should work with the 64bit kernel in the lifimage.

Yes, it did start booting with the 64 bit kernel with the "ip=bootip" option enabled, it just timed out when it couldn't find a valid tftp server. The second time that the timeout message came up, it gave up and rebooted automatically.

In addition I have updated the howto on
with info about this lifimage.
Please make sure that you install the 64bit kernel deb package before you reboot.

In case debootstrap (as documented in the wiki) fails, you could use the tarball from
to install with debootstrap.
Again, this tarball does not contain the 64bit kernel yet, so make sure to install it as well.

I'm very much interested in your feedback and findings.

Happy testing,

I'll keep plugging away at it as I have time. I'll let you know if I can get it to come up successfully.

Dave Land
Land Computer Service

Check out my site at http://www.landcomp.net

Reply to: