[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: D-I Etch Beta2 - Status update (4)

On Tue, Mar 07, 2006 at 02:17:02PM +0100, Frans Pop wrote:
> To avoid confusion, the direct link to the correct images is:
> http://cdimage.debian.org/cdimage/daily-builds/daily/arch-latest/$arch/iso-cd/

thanks for pulling this together and posting the message.

I tested the 2006.03.07 image for HPPA on my B2600:
-rw-r--r--  1 grundler grundler 126896128 Mar  7 23:54 debian-testing-hppa-netinst.iso
grundler <168>cksum debian-testing-hppa-netinst.iso 
3532889647 126896128 debian-testing-hppa-netinst.iso

The install had some nits and a major bug:
o initramfs package failed to install.  Retrying got past that.
o kernel package installed failed on the second try.  Retrying got past that.
o I went into the shell to snoop, noted that /sys and /proc
  was mounted 3 times. I was looking in /proc, not "mount" output.
  Makes sense if it doesn't get cleaned up after a failure.

After the install reported success and rebooted,
the system did not reboot:

Firmware Version 1.0                                                            
Duplex Console IO Dependent Code (IODC) revision 1                              
   (c) Copyright 1995-2000, Hewlett-Packard Company, All rights reserved        
  Processor   Speed            State           Coprocessor State  I/D Cache     
  ---------  --------   ---------------------  -----------------  ------------- 
      0      500 MHz    Active                 Functional         512 kB/1 MB   
  Central Bus Speed:                   120 MHz                                  
  Available memory:             1073741824 bytes                                
  Good memory required:           85463040 bytes                                
  Primary boot path:    FWSCSI.5.0                                              
  Alternate boot path:  FWSCSI.5.0                                              
  Console path:         GRAPHICS(2)                                             
  Keyboard path:        USB                                                     
----- Main Menu -------------------------------------------------------------   
      Command                           Description                             
      -------                           -----------                             
      BOot [PRI|ALT|<path>]             Boot from specified path                
      PAth [PRI|ALT|CON|KEY [<path>]]   Display or modify a path                
      SEArch [DIsplay|[[IPL] [<path>]]] Search for boot devices                 
      COnfiguration [<command>]         Access Configuration menu/commands      
      INformation [<command>]           Access Information menu/commands        
      SERvice [<command>]               Access Service menu/commands            
      DIsplay                           Redisplay the current menu              
      HElp [<menu>|<command>]           Display help for menu or command        
      RESET                             Restart the system                      
Main Menu: Enter command > sea fwscsi                                           
Searching for potential boot device(s)...  on Path FWSCSI                       
This may take several minutes.                                                  
To discontinue search, press any key (termination may not be immediate).        
   Path Number        Device Path              Device Type                      
   -----------        -----------------        -----------                      
   P0                 FWSCSI.6.0               QUANTUM ATLAS10KII-9LVD          
   P1                 FWSCSI.5.0               SEAGATE ST336704LC               
Main Menu: Enter command > bo p1                                                
Interact with IPL (Y, N, Q)?> n                                                 
Boot IO Dependent Code (IODC) revision 0                                        
HARD Booted.                                                                    
palo ipl 1.13 root@bld-4 Thu Jan  5 17:17:16 UTC 2006                           
Partition Start(MB) End(MB) Id Type                                             
1               1     133   f0 Palo                                             
2             134    7812   83 ext2                                             
3            7813    8789   82 swap                                             
4            8790   34726   83 ext2                                             
PALO(F0) partition contains:                                                    
    0/vmlinux32 3931288 bytes @ 0x48000                                         
Information: No console specified on kernel command line. This is normal.       
PALO will choose the console currently used by firmware (serial).               
Command line for kernel: 'root=/dev/sda2 HOME=/ console=ttyS0 TERM=vt102 palo_ke
Selected kernel: /boot/vmlinux from partition 2                                 
Selected ramdisk: /boot/initrd.img from partition 2                             
-------------- END OF OUTPUT -----------------

I did NOT use the default disk layout.
I want the PALO partition mounted as /boot with an ext2 FS type.

Besides any initramfs-tool problems that might have happened, the 
kernel and/or initrd might also have ended up past the 2GB block
limit on the root file system in partition 2. Normally palo loader
should complain if it's asked to load something beyond 2GB (byte)
address on the disk. 2GB is a limitation of parisc firmware.
I didn't see palo complain though.

The disk layout details are above:
1    palo (to be /boot)
2    /  (root)
3    swap
4    unused (to be /home)

Using the shell command line,  I ran:
	mount /dev/sda2 /mnt
	chroot /mnt

This is the default palo.conf on the target device (/mnt):
--commandline=2/boot/vmlinux root=/dev/sda2 initrd=2/boot/initrd.img HOME=/

and this is what I wanted:
--commandline=1/vmlinux root=/dev/sda2 initrd=1/initrd.img HOME=/

I ran "palo -v" and then to populated the new /boot with:
mount /dev/sda1 /mnt
mv /boot/* /mnt
umount /mnt

and edited /etc/fstab to add for sda1 and sda4:
/dev/sda2       /               ext3    defaults,errors=remount-ro 0       1
/dev/sda1       /boot           ext2    defaults,errors=remount-ro 0       2    
/dev/sda4       /home           ext3    defaults,errors=remount-ro 0       2    
/dev/sda3       none            swap    sw              0       0

(TO be fair, I told the installer to leave /dev/sda4 alone - existing
partition and filesystem).

I then "ifup eth0", ran dselect to update/install new bits from etch,
exited the chroot, and then on reboot, it all worked fine:

gggb2600:~# uname -a                                                            
Linux gggb2600 2.6.15-1-parisc #2 Mon Mar 6 17:26:58 GMT 2006 parisc GNU/Linux  


Reply to: