[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

want help: cant get runnig mouse on B180


Im trying to get running X on my B180.

I installed from debian 3.1 hppa netinstall
Without X and without Mouse everything seems to be okay.
But I cant get a mouse running

I can  start X ,  and login into gdm (and/or kdm) without any mousefunktion.

Its not a Hardwareproblem  hpux11 worked fine befor, I tryed a serial mouse 
too and 2 diffrent PS2 mouses :    -> no mouse funktion at all
Also with "gpm" : cant get any mouse funktion.
"mdetect" seems to recognise a ps2 intelli-mouse
 mdetect also recogise a mouse if NO mouse is connected !   :-(     

The following outputs of the commands is exactly the same 
with and without a mouse connected

uname -a :

Linux B180 2.6.8-2-32-smp #1 SMP Mon Feb 7 22:19:10 EST 2005 parisc GNU/Linux

dmesg | grep mouse
mice: PS/2 mouse device common for all mice
serio: GSC PS2 mouse port at 0xffd08100 irq 69 @ parisc8:16:8

ll /dev/psaux: 
crw-rw----  1 root root 10, 1 2005-08-03 19:31 /dev/psaux

lsmod | grep mouse
psmouse                29640  0


I: Bus=0011 Vendor=0001 Product=0002 Version=ab83
N: Name="AT Raw Set 2 keyboard"
P: Phys=parisc8:16:7/input0
H: Handlers=kbd event0
B: EV=120003
B: KEY=e080ffdf 1cfffff ffffffff fffffffe
B: LED=7
N: Number=0 Name=kbd
N: Number=1 Name=mousedev Minor=32
N: Number=2 Name=evdev Minor=64

XFree86.0.log | grep dev
(WW) Open APM failed (/dev/apm_bios) (No such file or directory)
(II) FBDEV: driver for framebuffer: fbdev
(II) FBDEV(0): using default device
(II) FBDEV(0): checking modes against framebuffer device...
(**) Option "Device" "/dev/input/mice"
(II) XINPUT: Adding extended input device "Configured Mouse" (type: MOUSE)
XFree86.0.log | grep EE
         (WW) warning, (EE) error, (NI) not implemented, (??) unknown.
(EE) FBDEV(0): FBIOPAN_DISPLAY: Invalid argument
XFree86.0.log |grep Mouse
(**) |-->Input Device "Configured Mouse"
(**) Configured Mouse: Protocol: "ImPS/2"
(**) Configured Mouse: Core Pointer
(**) Configured Mouse: Emulate3Buttons, Emulate3Timeout: 50
(**) Configured Mouse: ZAxisMapping: buttons 4 and 5
(**) Configured Mouse: Buttons: 5
(II) XINPUT: Adding extended input device "Configured Mouse" (type: MOUSE)
(II) Configured Mouse: ps2EnableDataReporting: succeeded

Questions:  1.  how can I  reliable test a mouse without X  ?
                    2. is it a kernel problem ?
                    3. what else can I do  ?

Any Ideas ?

Thanks in advance for a help .

PS: my debian 3.1  on my  "amd64 box"  works fine
 ( got it from Linuxtag in Karlsruhe   and did a small donation )

best Regards   

Franz Lebschi

Reply to: