[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

RE: FW: 2.4 -> 2.6

Dear Grant, Kyle and Thibaut:

	Thank you all very much! I now have a running 2.6.8-2-32-smp on my J6000. I
repartitioned sda to have the root right next to the f0 partition (and the
swap at the end) per Grant, modified /etc/mkinitrd/modules per Kyle and
added Kyle's patch to mkinitrd just for luck, rebooted and everything just
worked. sda did not become sdb. I will write this up to point out the
pitfalls newbies like me can hit, but I'm afraid I'm out of time to figure
out if, for instance, it works without Kyle's mods.

	It's great to be back among the living Debian hppa users! This J6000 is
going into production in China to run Web and mail services for my company



-----Original Message-----
From: Grant Grundler [mailto:grundler@parisc-linux.org]
Sent: Saturday, February 26, 2005 1:30 AM
To: Harry Cochran
Cc: Thibaut VARENE; debian-hppa@lists.debian.org
Subject: Re: 2.4 -> 2.6

On Fri, Feb 25, 2005 at 02:27:52PM -0500, Harry Cochran wrote:
> HARD Booted.
> palo ipl 1.5 root@c3k Tue Sep 21 15:14:05 MDT 2004
> Partition Start(MB) End(MB) Id Type
> 1               1      31   f0 Palo
> 2              32    1008   82 swap
> 3            1009   17366   83 ext2

This is an invalid partition scheme. It's just luck that it
worked with 2.4 kernel. I'm assuming partition 3 is the root partition.
Re-read http://en.tldp.org/HOWTO/PA-RISC-Linux-Boot-HOWTO/index.html.
In particular "4.3.3. Making a bootable partition".


-----Original Message-----
From: Kyle McMartin [mailto:kyle@mcmartin.ca]
Sent: Friday, February 25, 2005 11:27 PM
To: Harry Cochran
Subject: Re: FW: 2.4 -> 2.6

On Fri, Feb 25, 2005 at 10:20:28PM -0500, Harry Cochran wrote:
> Well, I tried 2.6.8-2-32-smp "out of the box" and got nowhere again. When
> booted with root=/dev/sda3 it didn't find it, so I changed to
> and it still didn't find it. Could I please hear from someone who has
> upgraded from 2.4 to 2.6 to let me know what they did STEP BY STEP.

The problem is 2.4 sucks, and with 2.6 we moved to doing things
exactly like the other architectures Debian supports.

One last thing to try that I can think of, is to add "sym53c8xx" to

This is how it looks on my C3000:

% cat /etc/mkinitrd/modules
# /etc/mkinitrd/modules: Kernel modules to load for initrd.
# This file should contain the names of kernel modules and their arguments
# (if any) that are needed to mount the root file system, one per line.
# Comments begin with a `#', and everything on the line after them are
# You must run mkinitrd(8) to effect this change.
# Examples:
#  ext2
#  wd io=0x300


Hope this helps,
	Kyle M.

Reply to: