[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

hppa d-i install report

Package: installation-reports


Debian-installer-version: http://people.debian.org/~jbailey/d-i/hppa/2004-11-24/2.6/mini.iso

uname -a: Linux legolas 2.6.8-1-32-smp #1 SMP Tue Nov 2 13:07:05 MST
2004 parisc GNU/Linux

Date: Wed, 24 Nov 2004 14:38:07 -0800
Method: Network install from ftp.us.debian.org, no proxy

Machine: HP PA-RISC J6000 workstation
Processor: 2x552MHz PA8600
Memory: 4GB
Root Device: SCSI (Quantum Atlas 10k 18G LVD)
Root Size/partition table:  

   Device Boot      Start         End      Blocks   Id  System
/dev/sda1               1          33       33776   f0  Linux/PA-RISC boot
/dev/sda2              34         157      126976   83  Linux
/dev/sda3             158       17366    17622016    f  W95 Ext'd (LBA)
/dev/sda5   *         158       16701    16941040   83  Linux
/dev/sda6           16702       17366      680944   82  Linux swap

sda2 is /boot, sda5 is /

Output of lspci and lspci -n:

legolas:~# lspci
0000:00:0c.0 Ethernet controller: Digital Equipment Corporation DECchip 21142/43 (rev 41)
0000:00:0d.0 Multimedia audio controller: Analog Devices AD1889 sound chip
0000:00:0e.0 IDE interface: National Semiconductor Corporation 87415/87560 IDE (rev 03)
0000:00:0e.1 Bridge: National Semiconductor Corporation 87560 Legacy I/O (rev 01)
0000:00:0e.2 USB Controller: National Semiconductor Corporation USB Controller (rev 02)
0000:00:0f.0 SCSI storage controller: LSI Logic / Symbios Logic 53C896/897 (rev 04)
0000:00:0f.1 SCSI storage controller: LSI Logic / Symbios Logic 53C896/897 (rev 04)
0000:01:01.0 Ethernet controller: Broadcom Corporation NetXtreme BCM5701 Gigabit Ethernet (rev 15)
0000:02:02.0 Display controller: Hewlett-Packard Company A4977A Visualize EG (rev 03)
legolas:~# lspci -n
0000:00:0c.0 0200: 1011:0019 (rev 41)
0000:00:0d.0 0401: 11d4:1889
0000:00:0e.0 0101: 100b:0002 (rev 03)
0000:00:0e.1 0680: 100b:000e (rev 01)
0000:00:0e.2 0c03: 100b:0012 (rev 02)
0000:00:0f.0 0100: 1000:000b (rev 04)
0000:00:0f.1 0100: 1000:000b (rev 04)
0000:01:01.0 0200: 14e4:1645 (rev 15)
0000:02:02.0 0380: 103c:1005 (rev 03)

Base System Installation Checklist:
[O] = OK, [E] = Error (please elaborate below), [ ] = didn't try it

Initial boot worked:    [O]
Configure network HW:   [E]
Config network:         [O]
Detect CD:              [ ]
Load installer modules: [O]
Detect hard drives:     [O]
Partition hard drives:  [O]
Create file systems:    [O]
Mount partitions:       [O]
Install base system:    [O]
Install boot loader:    [O]
Reboot:                 [E]


i cannot use the 2.4 image as the kernel is too old to boot on my test

The last image i tried was the Nov 11 snapshot. That one did not work
for me at all. This one was much better.

A few glitches - i am doing a net install, but the default kernel had no
driver for the tulip card that is common to almost all hppa systems. It
did find the tg3 addon card that i had in the system and i was able to
use it to do the install.

After reboot, the system did not come up automatically. This seems to be
because the initrd parameter was missing from the palo command line
installed by the installer. If i manually add initrd=2/initrd.img, then
the system boots up fine.

doing task installation it complained about not being able to install
some packages. i think it is the kernel-image package that it was
complaining about...... there was also a message about not being able to
install read-edid, altho that didn't seem to cause any problems.

oh, and please remove saveserial from the hppa package list. it's not
needed and causes all sorts of problems.

Randolph Chung
Debian GNU/Linux Developer, hppa/ia64 ports

Reply to: