[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

GNU/Libc 2.3.1 on HP-PARISC requires >= 2.4.19 kernel.

debian, parisc, debian-glibc,

Hi, my name is Carlos, and I cause all your nightmares with glibc on

Currently in unstable for HPPA - glibc 2.3.1-5
Currently in testing  for HPPA - glibc 2.2.5-15

During the changeover from GNU/Libc 2.2.x to 2.3.x HPPA has changed
it's minimum GNU/Libc kernel version to 2.4.19.

- More testing.
- Bugs fixed in unaligned handlers.
- Trap handler fixes.
- More things than you can shake a stick at, and all thanks to the
  wonderful kernel hacking team that parisc-linux has.

If you do not wish to upgrade your kernel then I suggest you pin glibc at
the particular version that you feel is good for you. The debian glibc
package for 2.3.1-6 has a preinst check against the system kernel version
(e.g. You can't install it without the right kernel).

I apologize for the initial oversight that meant there was no preinst
check, and one or two individuals have suffered through some serious
system reconstruction. I apologize. I really do. I owe you both beers :}

I recommend that you _do_ _not_ upgrade glibc on HPPA until 2.3.1-6.


glibc 2.3.1-6 is going into unstable in the next few days (time

Thanks for your time :)

Carlos O'Donell.

Reply to: