Re: upgrading libc6 from 2.2.5-14.3 to 2.3.1-5 fails on 712
On Tue, 26 Nov 2002, Randolph Chung wrote:
> > Then why doesn't the package itself depend on that kernel? If it did, apt
> > would have prevented the upgrade from ever being attempted at all...
> because anyone can compile a kernel themselves and install it, and dpkg
> only knows about debian packages.
While anyone indeed can, those who do ought to be shot dead. Reasonable people
use always kernel-package to make their own kernels. :)
> there might be a better way to check for this by using a preinst check.
> Carlos, can you take a look at this? I think sparc already a similar check.
This would be a very good idea, indeed.
> > I already did, a while back. See the thread when I asked about 712-specific
> > hardware and was told not to bother compiling any 2.4.18 kernel anymore.
> 2.4.18? i thought we were talking about 2.4.19....
I had tried 2.4.19, when recommended to do so, then reverted back to 2.4.18 when
I noticed how unstable 2.4.19 is on my hardware. My current 2.4.18 resulted in
the config I sent to Grant, which he added somewhere to the pa-risc site.
> yes, you should not use 2.4.18 anymore.
Why? 2.4.18 is the most stable I have seen in ages; it is rock-solid. I've had
nothing but troubles with 2.4.19, on but i386 and hppa.
Btw, the same libc6 2.3.1 on i386 does not require any particular kernel; it
works on 2.4.18 just fine.
> The 2.4.19-rc1 kernels are not particularly stable yet, but the pre-rc ones
> (e.g. the ones that are in the debian archive is 2.4.19-pa22) should be ok.
Noted. I usually build my own kernels, to remove as much excessive stuff as
"Kas sa tahad mind? - Nej!!! Är du en idiot?!!"