[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: [parisc-linux] Something broken in dpkg/dselect/apt?

> Tom wrote:
> > ...Shut it down, turned it on today, and now apt-get update
> > (or dselect update) fails. Updates download, then errors "Failed to fetch
> > -x-  rename failed, no such file or directory" and "couldn't stat -x- -
> > stat (2 no such file or directory". It then helpfully suggests that I
> > rerun the apt-get udpate...
> Grant:
> [ please follow up to debian-hppa list only ]
> I see this if I happen to upgrade when I think the mirrors are getting
> sync'd. Retrying a few hours later usually worked for me.
> Locally, the problem time was around 12-4PM PST for debian mirrors
> external to HP.

I got this, and also a suggestion that perhaps the clock was off, enough
so that the files didn't want to overwrite. This morning, I checked the
clock (within a few seconds) and tried to re-update, and it still fails.

Watching a reboot CLOSELY shows a couple little things: One, it's not
happy with the EISA card in slot 1. There's NO card in slot 1, but just to
humor it I'll probably tuck a 3c597 in there. Also, cron and at both give
an error on boot, saying they can't open or create their
/var/run/[apt|cron].pid files. gpm, inetd, etc. all created theirs, but
these two can't. dpkg-reconfigure cron or at gives the same error... I
checked permissions on /var and /var/run (all rwx for root) and in
/var/lib/apt (same). My next though is that perhaps /var is full, but this
is set up on a 4G drive, with sda1 16MB F0, sda2 33mb /boot, sda3 215mb
swap, and sda4 4027mb / (and / has 3G free, /boot has 15mb free).

The only other error (or even close to one) is that the system says it's
mounting unchecked file systems and wants me to run e2fsck manually. I
think my next step is booting from CD and checking both / and /boot. After
that, I'm stumped at this point...

To UNSUBSCRIBE, email to debian-hppa-request@lists.debian.org
with a subject of "unsubscribe". Trouble? Contact listmaster@lists.debian.org

Reply to: