[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

RE: fb support

I'm not sure what vid card I have but it's an old c240
I've tried the config file, and still no go, so I guess my card is not
dmesg attached

-----Original Message-----
From: Richard Hirst [mailto:rhirst@linuxcare.com]
Sent: Tuesday, March 19, 2002 1:07 PM
To: Kurc, Marcin A.
Cc: 'debian-hppa@lists.debian.org'
Subject: Re: fb support

On Tue, Mar 19, 2002 at 11:06:35AM -0500, Kurc, Marcin A. wrote:
> Hi,
> I'm trying to set up a framebuffer.
> I have the framebuffer support compiled into the kernel
> [*]   Generic STI frame buffer device support
> [*] STI console
> however, when I try to run fbset it says
> open /dev/fb0: No such device
> What did I miss? 

Don't know, but the config here


works, for h/w where frame buffer is currently supported.

What is your hardware?  Can you post dmesg output here?


To UNSUBSCRIBE, email to debian-hppa-request@lists.debian.org
with a subject of "unsubscribe". Trouble? Contact

Linux version 2.4.17-pa27 (root@ah0015) (gcc version 3.0.4) #2 Tue Mar 19 15:55:54 EST 2002
FP[0] enabled: Rev 0 Model 14
The 32-bit Kernel has started...
Determining PDC firmware type: System Map.
model 00005990 00000481 00000000 00000002 77a7282b 100000f0 00000008 000000b2 000000b2
vers  00000501
CPUID vers 14 rev 23 (0x000001d7)
model 9000/782/C240+
Total Memory: 768 Mb
On node 0 totalpages: 196608
zone(0): 196608 pages.
zone(1): 0 pages.
zone(2): 0 pages.
LED display at f0190001 registered
Kernel command line: root=/dev/sda2 HOME=/ console=tty0 sti=10/0/4/0 sti_font=VGA8x16 TERM=linux palo_kernel=2/boot/vmlinux
Console: colour dummy device 160x64
Calibrating delay loop... 470.22 BogoMIPS
Memory: 771168k available
Dentry-cache hash table entries: 131072 (order: 8, 1048576 bytes)
Inode-cache hash table entries: 65536 (order: 7, 524288 bytes)
Mount-cache hash table entries: 16384 (order: 5, 131072 bytes)
Buffer-cache hash table entries: 65536 (order: 6, 262144 bytes)
Page-cache hash table entries: 262144 (order: 8, 1048576 bytes)
Searching for devices...
Found devices:
1. U2-IOA BC Runway Port (12) at 0xfff88000 [8], versions 0x580, 0xf, 0xb
2. Dino PCI Bridge (13) at 0xf2000000 [8/0], versions 0x680, 0x2, 0xa,  additional addresses: 0xf2800000 
3. Raven U/L2 Dino RS-232 (10) at 0xf2003000 [8/0/63], versions 0x6, 0x0, 0x8c
4. Raven U/L2 Dino PS/2 Port (10) at 0xf2001000 [8/1], versions 0x6, 0x0, 0x96
5. Raven+ w SE FWSCSI Core BA (11) at 0xffd00000 [8/16], versions 0x56, 0x0, 0x81,  additional addresses: 0xffd0c000 0xffc00000 
6. Raven+ w SE FWSCSI Core Centronics (10) at 0xffd02000 [8/16/0], versions 0x56, 0x0, 0x74,  additional addresses: 0xffd01000 0xffd03000 
7. Raven+ w SE FWSCSU Core Audio (10) at 0xffd04000 [8/16/1], versions 0x56, 0x4, 0x7b
8. Raven+ w SE FWSCSI Core RS-232 (10) at 0xffd05000 [8/16/4], versions 0x56, 0x0, 0x8c
9. Raven+ w SE FWSCSI Core SCSI (10) at 0xffd06000 [8/16/5], versions 0x56, 0x0, 0x82
10. Raven+ w SE FWSCSI Core PS/2 Port (10) at 0xffd08000 [8/16/7], versions 0x56, 0x0, 0x84
11. Raven+ w SE FWSCSI Core PS/2 Port (10) at 0xffd08100 [8/16/8], versions 0x56, 0x0, 0x84
12. U2-IOA BC GSC+ Port (7) at 0xf203f000 [8/63], versions 0x501, 0x1, 0xc
13. U2-IOA BC Runway Port (12) at 0xfff8a000 [10], versions 0x580, 0xf, 0xb
14. Cujo PCI Bridge (13) at 0xf1000000 [10/0], versions 0x682, 0x1, 0xa,  additional addresses: 0xf1800000 0xf6000000 
15. Dino RS-232 (10) at 0xf1003000 [10/3], versions 0x7, 0x0, 0x8c
16. U2-IOA BC GSC+ Port (7) at 0xf103f000 [10/63], versions 0x501, 0x1, 0xc
17. Raven U 240 (9000/780/C240) (0) at 0xfffa0000 [32], versions 0x599, 0x0, 0x4
18. Memory (1) at 0xfffb1000 [49], versions 0x6f, 0x0, 0x9
CPU(s): 1 x PA8200 (PCX-U+) at 236.000000 MHz
Found U2 at 0xfff88000
Found U2 at 0xfff8a000
Lasi version 0 at 0xffd00000 found.
Dino version 3.0 found at 0xf2000000
The GSCtoPCI (Dino hrev 2) bus converter found may exhibit
data corruption.  See Service Note Numbers: A4190A-01, A4191A-01.
Systems shipped after Aug 20, 1997 will not exhibit this problem.
Models affected: C180, C160, C160L, B160L, and B132L workstations.

Cujo version 2.0 found at 0xf1000000
Enabling Cujo 2.0 bug workaround
POSIX conformance testing by UNIFIX
Linux NET4.0 for Linux 2.4
Based upon Swansea University Computer Society NET3.039
Initializing RT netlink socket
Enabled soft power switch (polling mode, io=0xf0140000).
Starting kswapd
Journalled Block Device driver loaded
parport_init_chip: initialize bidirectional-mode.
parport0: PC-style at 0xffd02800, irq 88 [PCSPP,TRISTATE]
STI PCI ROM enabled at 0xf1e00000
PCI graphic ROM found at f1e00000 (2048 kB), fb @ f6000000 (32 MB)
PCI region 0: f6000000 with 32768 kB
PCI region 1: 00000000 with 0 kB
PCI region 2: 00000000 with 0 kB
PCI region 3: 00000000 with 0 kB
PCI region 4: 00000000 with 0 kB
PCI region 5: 00000000 with 0 kB
PCI region 6: f1e00000 with 2048 kB
PCI region 7: 00000000 with 0 kB
PCI region 8: 00000000 with 0 kB
PCI region 9: 00000000 with 0 kB
PCI region 10: 00000000 with 0 kB
PCI region 11: 00000000 with 0 kB
Trying PCI STI ROM at f1e00000, PCI hpa at f6000000
sig 55aa0000, PCI STI ROM at f1e00044
STI word mode ROM at f1e00044, hpa=f6000000
STI word mode ROM, id 2fc1066b-9a02587, conforms to spec rev. 8.09
STI device: HPA4552A
pty: 256 Unix98 ptys configured
Serial driver version 5.05c (2001-07-08) with MANY_PORTS SHARE_IRQ SERIAL_PCI enabled
ttyS00 at iomem 0xffd05800 (irq = 90) is a 16550A
ttyS01 at iomem 0xf2003800 (irq = 106) is a 16550A
PS/2 keyboard port at 0xffd08000 (irq 69) found, device attached.
PS/2 psaux port at 0xffd08100 (irq 69) found, device attached.
lp0: using parport0 (interrupt-driven).
Generic RTC Driver v1.02 05/27/1999 Sam Creasey (sammy@oh.verio.com)
block: 128 slots per queue, batch=32
RAMDISK driver initialized: 16 RAM disks of 4096K size 1024 blocksize
Uniform Multi-Platform E-IDE driver Revision: 6.31
ide: Assuming 33MHz system bus speed for PIO modes; override with idebus=xx
loop: loaded (max 8 devices)
Linux Tulip driver version 0.9.15-pre9 (Nov 6, 2001)
tulip0: no phy info, aborting mtable build
tulip0:  MII transceiver #1 config 1000 status 782d advertising 0061.
eth0: Digital DS21143 Tulip rev 48 at 0xff00, 00:60:B0:B2:49:17, IRQ 96.
SCSI subsystem driver Revision: 1.00
sym53c8xx: at PCI bus 0, device 19, function 0
sym53c8xx: 53c875 detected 
sym53c875-0: rev 0x4 on pci bus 0 device 19 function 0 irq 99
sym53c875-0: ID 7, Fast-20, Parity Checking
scsi0 : sym53c8xx-1.7.3c-20010512
  Vendor: SEAGATE   Model: ST34520WS         Rev: HP03
  Type:   Direct-Access                      ANSI SCSI revision: 02
  Vendor: SEAGATE   Model: ST34520WS         Rev: HP03
  Type:   Direct-Access                      ANSI SCSI revision: 02
Attached scsi disk sda at scsi0, channel 0, id 5, lun 0
Attached scsi disk sdb at scsi0, channel 0, id 6, lun 0
sym53c875-0-<5,*>: FAST-20 WIDE SCSI 40.0 MB/s (50.0 ns, offset 15)
SCSI device sda: 8388314 512-byte hdwr sectors (4295 MB)
Partition check:
 sda: sda1 sda2 sda3
sym53c875-0-<6,*>: FAST-20 WIDE SCSI 40.0 MB/s (50.0 ns, offset 15)
SCSI device sdb: 8388314 512-byte hdwr sectors (4295 MB)
 sdb: unknown partition table
Lasi Harmony Audio driver V0.9a, h/w id 20, rev. 244 at 0xffd04000, IRQ 82
sticonsole_init: searching for STI ROMs
Console: switching to colour STI console 160x64
md: linear personality registered as nr 1
md: raid0 personality registered as nr 2
md: raid1 personality registered as nr 3
md: raid5 personality registered as nr 4
raid5: measuring checksumming speed
   8regs     :   517.600 MB/sec
   8regs_prefetch:   517.600 MB/sec
   32regs    :   402.400 MB/sec
   32regs_prefetch:   402.400 MB/sec
raid5: using function: 8regs_prefetch (517.600 MB/sec)
md: md driver 0.90.0 MAX_MD_DEVS=256, MD_SB_DISKS=27
md: Autodetecting RAID arrays.
md: autorun ...
md: ... autorun DONE.
NET4: Linux TCP/IP 1.0 for NET4.0
IP Protocols: ICMP, UDP, TCP, IGMP
IP: routing cache hash table of 8192 buckets, 64Kbytes
TCP: Hash tables configured (established 262144 bind 65536)
NET4: Unix domain sockets 1.0/SMP for Linux NET4.0.
VFS: Mounted root (ext2 filesystem) readonly.
Adding Swap: 127808k swap-space (priority -1)
eth0: Setting full-duplex based on MII#1 link partner capability of 01e1.

Reply to: