[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

question about newlibc and patch


Thanks to Matt Taggart and HP I am now the proud owner of a 712/80 :-)

Didn't have too much trouble getting it up and running, although I'm
seeing some oddities that I hope someone can kindly explain to me.

I saw a newlibc directory on pehc. are those debs ready for public
consumption? I had some problems installing them (mismatched symbols and
such) but haven't tried very hard. sticking with the old ones for now...

am also having some problems getting patch to work. i tried compiling it
both natively and cross-compiled from i386. it gives a 
	patch: **** fseek : Invalid argument
error when i try to use it. looks it it's being passed a whence
parameter that is invalid. From a cursory inspection of the code it
looks like all the calls to Fseek (a wrapper around fseek) are made with
SEEK_CUR, but a printf inside Fseek shows that it's passed some random
number. Any ideas?

I'm running:
Linux frodo.tausq.org 2.4.0-test6 #2 Sat Oct 7 12:01:42 MST 2000 parisc unknown
(from linux-latest on pehc)

and libc-2.1.92 
(from base-20000922.tar.gz on pehc)

Debian Developer <tausq@debian.org>

Reply to: