[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

transformers-0.4 is tricky


I looked into what it takes to upgrade to transformers-0.4, which is
required by e.g. the latest criterion. It takes a lot of upgrades.

But especially, it would require GHC-7.10, because leksah depends on
both "ghc" (the library) and transformers:

And I don’t believe we can do the same trick that we did for binary:
There will be packages using transformers which are used by both leksah
and, say, criterion: Against what package would we build that against?

So the way forwards seems to patch packages depending on transformers >
0.4 to be compatible with 0.3.


Joachim "nomeata" Breitner
Debian Developer
  nomeata@debian.org | ICQ# 74513189 | GPG-Keyid: F0FBF51F
  JID: nomeata@joachim-breitner.de | http://people.debian.org/~nomeata

Attachment: signature.asc
Description: This is a digitally signed message part

Reply to: