[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: Recommended versions on Hackage and Debian

Dear Simon,

Am Sonntag, den 16.02.2014, 14:01 +0100 schrieb Simon Hengel:
> Hi Joachim,
> I'm planning to release a technology preview for Hspec 2.0 to Hackage.
> I'd releases it as 1.99.0  and set the preferred versions for Hspec to <
> 1.99 on Hackage.
> Distributors should not package 1.99.*.
> Does this approach cause any issues for Debian? (Say, do you take
> Hackage's preferred versions into account when packaging?)

currently, we are not very aware of preferred versions, so it might
happen that someone accidentally package a non-preferred version.

Can Cabal be instructed to not consider non-preferred versions, and
print an error/warning otherwise? In that case, we could add that to our
upgrade-planning-tool (which uses cabal).

If you mention that something is not production ready in the package
description, that would also have good chances of not slipping into


Joachim "nomeata" Breitner
Debian Developer
  nomeata@debian.org | ICQ# 74513189 | GPG-Keyid: 4743206C
  JID: nomeata@joachim-breitner.de | http://people.debian.org/~nomeata

Attachment: signature.asc
Description: This is a digitally signed message part

Reply to: