[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Broken gnome after update...



Hi,

I run Debian testing on my machine and then I have some apps from
unstable (like gnome-core, galeon aso). I updated galeon (and some other
app I think) past friday, with this update I got some extra upgrades
like gnome-control-center and I also got bonobo-activation updated. The
interesting thing was that after the upgrade I couldn't start gnome at all.
I looked at the lists and blamed bonobo-activation but after some
research I fountout that it was not the problem. (I logged in with
session xterm failsafe and could start the panels and nautilus).
I found out that if I downgraded gnome-control-center to the version in
testing (for gnome 1.4) the problem went away, so I guess the
gnome-settings-daemon is the bad guy.

Another observation I made was that when I tried to login with the bad
control-center I sometimes got a message in some systemlog that file-max
limit was reached. If I did a lsof during login I see alot of
gnome_segv2 entries with the same PID opening pipes.
If I when I started a xterm only starts metacity, nautilus and
gnome-settings-daemon in that order I get a crach in gnome_segv2... I
don't know how things are supposed to work so I can't say for sure that
this isn't the way is should work.

So to summarize, I have a bad gnome-control-center which prevents me
from loggin in to gnome.
I also see strange gnome_segv2 entries with lsof, and gnome_segv2 seems
to crash sometimes.

Am I the only one with this problem? Have nobody had problems with the
new control-center?.

I can also mention that yesterday I did a full downgrade to testing,
logged in to gnome and got some thing working (mixed gnome1.4 and gnome2
but it started). I then installed just gnome-core and things wouldn't start.

//Mattias Eriksson







Reply to: