[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Bug#914999: [libc6] Locking problems into libc6



control: tag -1 + moreinfo

Hi,

On 2018-11-29 13:58, Roman Savochenko wrote:
> Package: libc6
> Version: 2.24
> Severity: critical
> 
> --- Please enter the report below this line. ---
> I have got already more signs of a problem into locking access to functions
> like to getaddrinfo(), by the macro __libc_lock_lock, which reproduced in
> multithreaded environments!
> 
> 1. For my program, I was needed to create extra locking about the function
> getaddrinfo(), but that resolved the problem only for my calls but for the
> external libraries like to MySQL, MariaDB I yet have the crashes and it
> cannot be fixed at all.

Can you give more details about the issue, the symptoms, possible crash
backtrace, way to reproduce it. Without this details, there are very few
chances to be able to fix the bug.

> 2. rtl8192eu by the driver rtl8xxxu, or the external one 8192eu.ko, does not
> connect to any network with that messages into dmesg:
> [  137.936642] wlx000f0064f2d8: authenticate with 00:90:4c:08:00:0d
> [  137.940680] wlx000f0064f2d8: send auth to 00:90:4c:08:00:0d (try 1/3)
> [  138.145146] wlx000f0064f2d8: send auth to 00:90:4c:08:00:0d (try 2/3)
> [  138.353198] wlx000f0064f2d8: send auth to 00:90:4c:08:00:0d (try 3/3)
> [  138.557239] wlx000f0064f2d8: authentication with 00:90:4c:08:00:0d timed
> out

glibc is not involved at all in the wireless driver, so I don't see the
relation with the previous issue.

> 3. Impossible to connect to any WLan HotSpot (Ad-hoc), for me it is Nokia N9

Without more details, I also fail to see the relation with glibc here.

> All those issues fine fork on two Debian 8 installations with the libc6
> 2.19, where one on the same hardware as Debian 9.
> Other Debian 9 installation on the stationary PC also does not work for the
> second issue.
> Initially I heve counted it is kernel problems but I have installed this
> same Linux kernel version on Debian 8 and these all work there.

There are thousands of packages in different versions between Debian 8
and Debian 9. You have found it's not related to the kernel, but I fail
to see how that shows it's a libc6 issue. For example when you have
tried the kernel from Debian 9 in Debian 8, have you also tried with the
rtl8192 firmware from Debian 9?

Anyway if we want to know that the problem is related with glibc, please
try to install glibc packages (libc*, possibly locales* and nscd if
needed) from Debian 9 onto a working Debian 8 installation and see if
the problem appears.

Without more information, there is no way for us to fix the bug, so
we'll just have to close it.

Thanks,
Aurelien

-- 
Aurelien Jarno                          GPG: 4096R/1DDD8C9B
aurelien@aurel32.net                 http://www.aurel32.net

Attachment: signature.asc
Description: PGP signature


Reply to: