[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Bug#759530: libc-bin: ldconfig breaks a system

On Thu, Aug 28, 2014 at 10:07:57AM +0400, Dmitrii Kashin wrote:
> Package: libc-bin
> Version: 2.19-9
> Severity: grave
> File: /sbin/ldconfig
> Dear Maintainer,
> I had an upgrade of libc6 and libc-bin packages up to the version
> 2.19-9 from 2.19-4 while executing `apt-get upgrade'. In the begin it
> seemed as a usual upgrade but after a while (supposedly after these two
> packages) an upgrade was interrupted showing numerous "segmentation
> fault" errors.
> Then almost for every command in shell I got "segmentation fault". I was
> surprised. I tried to log into another tty, but failed. Then I tried to
> reboot... And got a kernel panic after 2 seconds of system bootstrap.
> I took a livecd. I failed to chroot (got the same "segfault problem"). I
> supposed that I had some problems with libc6, so I took a package
> libc6_2.19-9_amd64.deb from /var/cache/apt/archives and unpacked it into
> the root mount point via `dpkg-deb -x <pkg>'. After that I managed to
> chroot into the system.
> I tried to finish an upgrade process, but I got the same faults.
> I put here inline the first lines of `apt-get upgrade' output:
> --------------------
> # apt-get upgrade
> Reading package lists...
> Building dependency tree...
> Reading state information...
> The following packages were automatically installed and are no longer required:
>   alsa-base libabw-0.0-0 libcdr-0.0-0 libe-book-0.0-0 libetonyek-0.0-0
>   libfreehand-0.0-0 libgeoclue0 libmspub-0.0-0 libmwaw-0.2-2 libodfgen-0.0-0
>   liborcus-0.6-0 libvisio-0.0-0 libwpd-0.9-9 libwpg-0.2-2 libwps-0.2-2
> Use 'apt-get autoremove' to remove them.
> 0 upgraded, 0 newly installed, 0 to remove and 1 not upgraded.
> 108 not fully installed or removed.
> After this operation, 0 B of additional disk space will be used.
> Setting up liblcms2-2:i386 (2.6-3) ...
> Setting up libmbim-glib0:amd64 (1.8.0-1) ...
> dpkg: error processing package libmbim-glib0:amd64 (--configure):
>  subprocess installed post-installation script was killed by signal (Segmentation fault)
> Setting up libmm-glib0:amd64 (1.2.0-1) ...
> dpkg: error processing package libmm-glib0:amd64 (--configure):
>  subprocess installed post-installation script was killed by signal (Segmentation fault)
> Setting up libmng1:i386 (1.0.10+dfsg-3.1) ...
> ...
> --------------------
> After it I had to unpack libc6 package again.
> Then I looked intently at the first package with problems
> (libmbim-glib0). I unpacked it and saw in the postinst script the
> command `ldconfig'.
> After a while I realized that "segfaults" happen after and only after
> execution of `ldconfig'.
> I managed with the problem by downgrading libc6 and libc-bin (amd64 and
> i386 versions both, because I'm using multiarch) back to the version
> 2.19-4 from the apt cache.

For me it looks like the ld.so symlink is overriden when running
ldconfig, a bug which is supposed to be fixed months ago. Can you please
give me the list of libc packages installed on your system by running
the "dpkg -l libc*" command? Also what is the output of "which

Aurelien Jarno                          GPG: 4096R/1DDD8C9B
aurelien@aurel32.net                 http://www.aurel32.net

Reply to: